Bug 398211 - reversed meaning on "Include remote tests" in SA junk mail plugin
reversed meaning on "Include remote tests" in SA junk mail plugin
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 04:23 EST by Dan Horák
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 19:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 499644 None None None Never

  None (edit)
Description Dan Horák 2007-11-25 04:23:24 EST
There is a config option (a checkbox) in the Junk mail settings, which is called
"Include remote tests" for the Spamassassin mail filter. Corresponding gconf
variable is "/apps/evolution/mail/junk/sa/local_only". But they are in the
opposition - when "Include remote tests" is checked, then "local_only" is set
too and looks like that only local tests are done. When unchecking, then the
filtering process takes longer and is also more precise.

Version-Release number of selected component (if applicable):
evolution-2.12.1-3.fc8
evolution-2.21.2-2.fc9

The source file is evolution/plugins/sa-junk-plugins/em-junk-filter.c
Comment 1 Matthew Barnes 2007-11-25 19:58:10 EST
Indeed, you're right:

check = gtk_check_button_new_with_mnemonic (_("I_nclude remote tests"));
...
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (check), em_junk_sa_local_only);


Forwarding this upstream with a patch.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=499644

Note You need to log in before you can comment on or make changes to this bug.