Bug 39858 - Bad: g++ Segfaults while compiling JDK 1.3.1 sources
Bad: g++ Segfaults while compiling JDK 1.3.1 sources
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 44759 52905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 09:22 EDT by Parag Warudkar
Modified: 2007-03-26 23:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-10 06:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Warudkar 2001-05-09 09:22:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
While compiling JDK 1.3.1 sources, g++ segfaults on compiling file 
byteCode.cpp from the unchanged source distribution downloaded from sun.

How reproducible:
Always

Steps to Reproduce:
1.Get the JDK sources
2.Follow the instructions
3.start compile. Wait until it segfaults.:)
	

Actual Results:  G++ : Segmentation fault.

Expected Results:  Should have compiled the whole JDK w/o problems.

Additional info:

g++ -v : Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)

uname -a : Linux cvsrepo 2.2.19-7.0.1 #1 Tue Apr 10 01:23:42 EDT 2001 i586 
unknown
All latest patches applied to RH7.0
Comment 1 Jakub Jelinek 2001-05-10 06:35:44 EDT
See my patch http://gcc.gnu.org/ml/gcc-patches/2001-05/msg00504.html
What is interesting is that if JDK stopped "optimizing" this way, the generated
code could be much better (it could be actually inlined).
Comment 2 Jakub Jelinek 2001-06-07 09:09:57 EDT
I've included this patch in gcc-c++-2.96-86.
Comment 3 Jakub Jelinek 2001-06-22 06:32:50 EDT
*** Bug 44759 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2001-09-06 13:42:55 EDT
*** Bug 52905 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.