Bug 398641 - Firefox often crashes
Firefox often crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libflashsupport (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 14:37 EST by Mads Kiilerich
Modified: 2008-05-27 17:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 17:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of bugbuddy crash report (585.59 KB, text/plain)
2007-11-25 14:37 EST, Mads Kiilerich
no flags Details
another bugbuddy report - this time with symbols (17.34 KB, text/plain)
2007-11-26 16:53 EST, Mads Kiilerich
no flags Details
"thread apply all bt" from youtube crash (8.80 KB, text/plain)
2007-12-11 18:17 EST, Mads Kiilerich
no flags Details
npviewer.bin bugbuddy report (8.06 KB, text/plain)
2008-03-22 11:56 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2007-11-25 14:37:17 EST
Description of problem:
Firefox very often crashes, not completely reproducible.

Version-Release number of selected component (if applicable):
firefox-2.0.0.9-1.fc8
libflashsupport-000-0.1.svn20070904
flash-plugin-9.0.48.0-release
jre-1.6.0_03-fcs
enabled add-ons: firebug, dom inspector and mugshot

How reproducible:
Happens regularly, apparently mostly on "complex" pages with flash etc

Additional info:
I know that 3rd party plugins isn't "supported", but to the regular user it will
appear as a fedora problem, and fedora thus should have interest in solving it -
or at least document what the problem is and who to blame.
Comment 1 Mads Kiilerich 2007-11-25 14:37:18 EST
Created attachment 268311 [details]
example of bugbuddy crash report
Comment 2 Mads Kiilerich 2007-11-26 16:53:38 EST
Created attachment 269321 [details]
another bugbuddy report - this time with symbols

(firefox-debuginfo-2.0.0.9-1.fc8.i386.rpm isn't available in the yum repo, got
it from koji)
Comment 4 John Bass 2007-12-01 21:35:46 EST
Sites that crash firefox for me today after upgrade.

This crashes with both javascript and java disabled.

    http://www.intersil.com/isl6291/ 

This crashes with javascript enabled (java disabled), works when javascript
disabled:

    http://www.wunderground.com/cgi-bin/findweather/getForecast?query=80538
Comment 5 Mads Kiilerich 2007-12-03 15:21:08 EST
John: The links seems to work fine here :-(

Is the crashes reproducible for you?

If so, could you try to find out what trigs it? Some combination of: Could you
try  from another (new) user account? Could you try with all your add-ons
disabled? And uninstalled? And with plugins?


I wonder if running under valgrind would help. But judging from for example
http://www.squarefree.com/2007/09/20/firefox-memory-usage-and-memory-leak-news/
there seems to be known leaks not yet fixed in FF2...
Comment 6 Matěj Cepl 2007-12-04 05:35:55 EST
Really cannot reproduce neither crash with either URL you proposed. What JVM you
have?

Please try suggestions from comment 5 (and with yum upgrade) and let us know the
results.
Comment 7 Matěj Cepl 2007-12-05 10:10:26 EST
Does installing libflassupport helps?
Comment 8 Mads Kiilerich 2007-12-05 10:56:53 EST
As mentioned above: I have libflashsupport-000-0.1.svn20070904 installed. Don't
know about John Bass. He isn't on the CC list ...
Comment 9 Matěj Cepl 2007-12-06 05:36:40 EST
I am sorry, I missed that.
Comment 10 Mads Kiilerich 2007-12-06 06:29:32 EST
BUT yesterday, with firefox-2.0.0.10, I just got almost-reproducible crashes on
youtube. 

I uninstalled all add-ons and plugins except flash. It still crashed.

I noticed in about:plugins that there were two flash plugins (IIRC 9.0 r8 and
r119), but the only flash plugin I could find in the filesystem was
/usr/lib/firefox-2.0.0.10/plugins/libflashplayer.so ->
/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so ->
/usr/lib/flash-plugin/libflashplayer.so

I uninstalled flash rpm (from adobe) and installed it again, and it still
crashed. (I'm however not 100% sure about this...)

But when I uninstalled libflashsupport and installed it again then things seemed
to start working. And then I ran out of time...

So it might be libflashsupport related anyway ...
Comment 11 Matěj Cepl 2007-12-06 12:47:04 EST
To me it looks like something between flash-player and libflashsupport.
Reassigning to the latter.
Comment 12 Mads Kiilerich 2007-12-11 18:17:36 EST
Created attachment 284761 [details]
"thread apply all bt" from youtube crash

stacktraces shows that crash happens deep inside libflashplayer.so
Comment 13 Lubomir Kundrak 2008-03-06 01:41:05 EST
Mads: Would it be possible for you to get a stacktrace with debugging symbols
installed? If yes, installing debugging information for firefox and
libflashsupport with debuginfo-install from yum-utils might help a lot.

Thanks!
Comment 14 Mads Kiilerich 2008-03-06 05:40:57 EST
Lubomir: I think the attachment from #12 already has the stacktrace with
debugging symbols you request. Or what am I missing?

I didn't know debuginfo-install - thanks for the tip ;-)
Comment 15 Mads Kiilerich 2008-03-22 11:44:25 EDT
Lubomir: For the last couple of weeks I haven't seen this problem on any of my
machines, so it might have been solved by some update.

Another possibility is that I perhaps for some reason didn't have
nspluginwrapper installed. Coincidence or not: now I have it installed and I
don't see any crashes.
Comment 16 Mads Kiilerich 2008-03-22 11:56:07 EDT
Created attachment 298845 [details]
npviewer.bin bugbuddy report

FWIW bugbuddy pops up with this npviewer.bin crash. The crash can however be
ignored and firefox continues to run. But the crash seems be the same as the
one I got before - something with flash messing something up. But fortunately
the pluginwrapper mitigates the problem.
Comment 17 Mads Kiilerich 2008-04-29 17:34:50 EDT
nspluginwrapper seems to solve the problem for me. So as far as I am concerned
the issue can be closed.

But using nspluginwrapper on i386 just to avoid crashes seems to be abuse.
Someone who knows nspluginwrapper might want to investigate the issue further.

Note You need to log in before you can comment on or make changes to this bug.