Bug 398861 - software updater will not run do to a missing dependency file
software updater will not run do to a missing dependency file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 18:15 EST by Phil Speck
Modified: 2013-07-02 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 11:05:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
software updater will not run do to a missing dependency file (891.96 KB, image/png)
2007-11-25 18:15 EST, Phil Speck
no flags Details

  None (edit)
Description Phil Speck 2007-11-25 18:15:39 EST
Description of problem:

Software updater tells me t0 install 265 updates.

Software updater fails and will not install any updates even if I uncheck all
but one (1) item.

The error reports a missing file in curl 7.17.1-1.fc8-delevl

I have downloaded, complied and installed curl 7.17.1-1.fc8-delevl and that
isn't working
 


Version-Release number of selected component (if applicable):

fedora 8

How reproducible:

Continously

Steps to Reproduce:
1. Click on the software updater
2.
3.
  
Actual results:

loads the list, and creates the dependency file

Expected results:
Software updater to work

Additional info:

Attached is a screen shot or the error.
Note I have tried this a normal user and as root, and I end with the same results.
Comment 1 Phil Speck 2007-11-25 18:15:39 EST
Created attachment 268381 [details]
software updater will not run do to a missing dependency file
Comment 2 Bryan Hundven 2008-01-08 03:35:37 EST
I also get the same.

Granted. I don't recommend logging into X as root (sudo rocks!).

I do get:

Missing Dependency: curl = 7.17.1-1.fc8 is needed by package curl-devel

Although I have this in my updates: curl - 7.17.1-4.fc9.i386 updates curl -
7.17.1-1.fc8.i386

It seems that curl-devel is not getting updated. My solution was to remove
curl-devel, after that my update continued.

Maybe this bug should be called "Please make a curl-devel package for the fc9
branch" and change the version on the bug to rawhide.
Comment 3 Michael Schwendt 2008-04-05 11:05:17 EDT
This clearly has not been a bug in the curl packaging.
It would have been better to discuss/analyse such a problem
on fedora-list with proper output from rpm and yum.

The one in comment 2 is a different issue, because curl-devel was
renamed to libcurl-devel without a proper Obsoletes (bug 429612).

Note You need to log in before you can comment on or make changes to this bug.