Bug 398931 - sendmail updates overwrites custom sedmail configuration
sendmail updates overwrites custom sedmail configuration
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 20:26 EST by Alexandre Oliva
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-30 10:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2007-11-25 20:26:00 EST
Description of problem:
The last few sendmail updates have restarted sendmail using a standard
configuration, rather than my local customized configuration, causing loss and
delay of messages.  It's a terrible idea for a sendmail upgrade to override a
modified configuration and restart the daemon without the modifications.  It
would be better to leave the modified configuration in place (which rpm claims
to do, storing the new config in .rpmnew) and restart the new daemon with it. 
Then, if it fails to restart, at least it won't lose messages and the failure
will be noticed relatively quickly.

Oddly, there are sendmail.cf.rpmnew files left behind after the latest update. 
This is probably an artifact of having got both i386 and x86_64 versions of
sendmail.cf installed.  RPM has some trouble with configuration files modified
as part of the current transaction when the other-arch build of the package
attempts to install it too.

Version-Release number of selected component (if applicable):
sendmail-8.14.2-1
sendmail-8.14.1-4.2
Comment 1 Thomas Woerner 2007-11-30 10:00:18 EST
You shound not modify sendmail.cf by hand. Please use sendmail.mc for
customizations. Service sendmail start will create a new sendmail.cf, if at
minimum one of the mc files is newer than the cf file.

Closing as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.