Bug 399191 - mozilla-plugin-config not listed in provides section of packaging (spec file?)
mozilla-plugin-config not listed in provides section of packaging (spec file?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 02:40 EST by Kam Leo
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 06:31:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kam Leo 2007-11-26 02:40:44 EST
Description of problem:

It's hard to install/get mozilla-plugin-config if yum cannot tell you to which
package it belongs.

E.g. 

$$ sudo yum provides mozilla-plugin-config
No Matches found

Please add mozilla-plugin-config to the "Provides" or appropriate section of
package.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Execute "sudo yum provides mozilla-plugin-config"
2.
3.
  
Actual results:
No Matches found

Expected results:
nspluginwrapper - 0.9.91.5-8.fc8.i386 

Additional info:
Comment 1 Kam Leo 2007-11-26 03:18:06 EST
Just to keep things tidy: 

$sudo yum search mozilla-plugin-config
nspluginwrapper.i386 : A compatibility layer for Netscape 4 plugins

So if you are well versed in yum you can find the package.

Thus my bug is why shouldn't the "provides" switch have worked with yum for this
package?
Comment 2 Martin Stransky 2007-11-26 06:31:07 EST
Use the "whatprovides" yum directive:

[root@dhcp-lab-232 ~]# yum whatprovides "/usr/bin/mozilla-plugin-config"
Loading "firefox-plugin" plugin
nspluginwrapper.i386 : A compatibility layer for Netscape 4 plugins
nspluginwrapper.x86_64 : A compatibility layer for Netscape 4 plugins
nspluginwrapper.x86_64 : A compatibility layer for Netscape 4 plugins
nspluginwrapper.i386 : A compatibility layer for Netscape 4 plugins

Note You need to log in before you can comment on or make changes to this bug.