Bug 399371 - Unable to start sealert
Unable to start sealert
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 07:03 EST by Adam Huffman
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 17:31:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2007-11-26 07:03:49 EST
Description of problem:
I've had a number of problems since upgrading to F8, some of which are SELinux
related.  Unfortunately, the sealert applet is not starting properly, which
doesn't help in fixing these problems.

Version-Release number of selected component (if applicable):
setroubleshoot-server-1.10.7-1.fc8

How reproducible:


Steps to Reproduce:
1. sealert should start at user login
2.
3.
  
Actual results:

sealert does not start

2007-11-26 11:56:11,863 [program.ERROR] exception ImportError: No module named
gui_utils
Traceback (most recent call last):
  File "/usr/bin/sealert", line 906, in <module>
    from setroubleshoot.gui_utils import *
ImportError: No module named gui_utils
Traceback (most recent call last):
  File "/usr/bin/sealert", line 936, in <module>
    from setroubleshoot.gui_utils import *
ImportError: No module named gui_utils


Expected results:


Additional info:
Comment 1 John Dennis 2007-11-26 13:15:53 EST
I suspect you're missing at least one if not two packages, please make sure
setroubleshoot and setroubleshoot-plugins are installed.

The missing file is in setroubleshoot rpm which contains the GUI components.

If install/upgrade the setroubleshoot and setroubleshoot-plugins rpms does the
problem go away?
Comment 2 Adam Huffman 2007-11-26 16:08:52 EST
The plugins package was installed, but not setroubleshoot itself.  I've just
installed that and it seems to have fixed the problem, so sorry for the
misleading report.

However, doesn't this mean that some dependency is missing somewhere?
Comment 3 John Dennis 2007-11-26 17:31:26 EST
> However, doesn't this mean that some dependency is missing somewhere?

It probably means sealert shouldn't be in the setroubleshoot-server package as
it is currently. The reason it's there is because sealert can be run as a
command-line tool without a GUI. Having a single program (sealert) function in
both GUI and non-GUI modes is probably the root cause and perhaps we should fix
this. The setroubleshoot-server package was split off of setroubleshoot for
folks who did not want to pull in GUI dependencies on server or headless
machines which otherwise would have no GUI packages installed.

Note You need to log in before you can comment on or make changes to this bug.