Bug 399551 - Update of 'which' leads to 'install-info' complaint
Update of 'which' leads to 'install-info' complaint
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: which (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 10:40 EST by Joachim Frieben
Modified: 2008-01-25 05:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 05:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-11-26 10:40:14 EST
Description of problem:
'install-info' complains about missing info dir entry in
  `/usr/share/info/which.info.gz'

Version-Release number of selected component (if applicable):
which-2.18-3.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Update to which-2.18-3.fc9
  
Actual results:
Package is installed but the following message is returned to the
console: 'install-info: warning: no info dir entry in
  `/usr/share/info/which.info.gz''

Expected results:
Package installs without complaint.

Additional info:
The latest entry to the changelog seems to be related to the issue,
* Mon Nov 26 2007 Karsten Hopp <karsten@redhat.com> 2.18-3
- add dir entry for info page
Comment 1 Ngo Than 2007-11-26 12:57:00 EST
it's the bug in previous version, which printed the warning. It's now fixed in 
which-2.18-3.fc9
Comment 2 Joachim Frieben 2007-11-26 13:12:19 EST
However, executing 'rpm -Uhv --force which-2.18-3.fc9.x86_64.rpm' after
updating the package still issues this warning.
Comment 3 Ngo Than 2007-11-27 05:14:52 EST
because the postinstall scriptlet of the previous which version is used!
if you delete which with "rpm -e which" and install it after that you won't 
see this warning.
Comment 4 Joachim Frieben 2007-11-27 18:24:41 EST
(In reply to comment #3)
I actually do, and this even for which-2.18-4.fc9.
Comment 5 Michal Jaegermann 2007-11-28 21:09:36 EST
/usr/share/info/which.info.gz is missing close to the beginning
a stanza of that sort:

INFO-DIR-SECTION Basics
START-INFO-DIR-ENTRY
* Which: (which).               Show the full path of (shell) commands.
END-INFO-DIR-ENTRY

The net effect is only a complaint, which is less important,
but 'which' is also not added to info directory and if you will
type 'info' it will not show up among displayed topics.

That is the case for the current rawhide updates.
Comment 6 Michal Jaegermann 2007-11-29 14:33:08 EST
'rpm -q --changelog which' sports the following:

* Mon Nov 26 2007 Karsten Hopp <karsten@redhat.com> 2.18-3
- add dir entry for info page

Maybe this was an intention but as of which-2.18-5.fc9 this is
still not there so the complaint shows up and no dir entry
after an update.
Comment 7 petrosyan 2008-01-24 16:16:24 EST
This bug has been fixed in which-2.19 which can be downloaded from
http://www.xs4all.nl/~carlo17/which/
Comment 8 Ngo Than 2008-01-25 05:56:47 EST
it's fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.