Bug 39965 - Aironet 4800 pcmcia-cs wireless causes failed configuration and kernel panic on exit
Summary: Aironet 4800 pcmcia-cs wireless causes failed configuration and kernel panic ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-09 23:05 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 16:24:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the output of /var/log/messages after removing the xircom cardbus enet card and inserting the aironet card. The last message is a shutdown.. (26.00 KB, text/plain)
2001-05-09 23:09 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-05-09 23:05:50 UTC
Description of Problem:
  I have an aironet 4800 turbo ds card that works fine w/ the standalone 
pcmcia-cs (both w/ 2.2/2.4 kernels) (dell 5000e) However w/ rh7.1 and the 
kernel subsystem I get all sorts of dire warnings on enter : (log file attached).
On exit I get a kernel panic and the system freezes (I can shut down normally 
however... ) I am attaching a log file of the "dire warnings" but not of the kernel 
panic as I'd rather not reproduce that. (I cleaned my system then), but will if you 
guys feel its important ..


How Reproducible:
All the time

Steps to Reproduce:
1. boot up w/ aironet card in or standard enet card
2. remove standard enet card and insert aironet card
3. read /var/log/messages
4. remove aironet card 
Actual Results:
 kernel panic!

Expected Results:
 Happiness for one's no longer connected to the net dell5ke :)

Additional Information:

Comment 1 Need Real Name 2001-05-09 23:09:46 UTC
Created attachment 17949 [details]
this is the output of /var/log/messages after removing the xircom cardbus enet card and inserting the aironet card. The last message is a shutdown..

Comment 2 Arjan van de Ven 2001-05-10 08:19:14 UTC
Can you check if you are using the airo_cs or the aironet4500_cs driver ?
And could you try the other one ?


Comment 3 Arjan van de Ven 2001-05-16 17:24:11 UTC
An other reporter confirmed that changing to the airo_cs driver fixed the
problem. For the next version of kernel-pcmcia-cs, this will become the default
for your card. Could you edit /etc/pcmcia/config and change this ? That should
fix your problem.

Comment 4 Aleksey Nogin 2001-07-31 16:17:14 UTC
Using airo_cs driver with kernel-2.4.3-12.i686 causes a new set of problems -
after doing one or two couple of cardctl eject/cardctl insert, I would see a
kernel oops and the system would get into some rather weird state, although some
of the shutdown scripts would still work somewhat.

I didn't notice this problems and reported in bug 40552 that airo_cs was OK for
me since until a few days ago I only used RH7.1+aironet card on my desktop,
where I never tried unplugging the card (also, desktop is SMP and is running SMP
kernel, so things may be different there - not that I want risk testing that :-) ).

However, using the kernel-2.4.6-3.1 and kernel-pcmcia-cs-3.1.27-5 from Rawhide
seems to solve all my problems.

Comment 5 Aleksey Nogin 2001-07-31 16:24:49 UTC
Sorry, didn't mean to change the status.

Comment 6 Aleksey Nogin 2002-05-01 16:06:36 UTC
I believe this problem no longer exists in 7.2


Note You need to log in before you can comment on or make changes to this bug.