Bug 399711 - fence_apc fencing agent doesn't work on 3.3.x firmware.
fence_apc fencing agent doesn't work on 3.3.x firmware.
Status: CLOSED DUPLICATE of bug 396581
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Jim Parsons
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 12:47 EST by Shih-Hsin Yang
Modified: 2009-04-16 18:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 02:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The /tmp/apclog for power off port 2, port off port 6 (10.10 KB, application/octet-stream)
2007-11-26 12:47 EST, Shih-Hsin Yang
no flags Details

  None (edit)
Description Shih-Hsin Yang 2007-11-26 12:47:08 EST
Description of problem:

I'm using RHEL AP 5.1, cman-2.0.73-1.
fence_apc script doesn't work on APC power switch.

But weird thing is,
whenever I tried to Off/On the 1,3,4,5,6,7,8 port of power switch, there's no error.

The error occured when I Off/On the port 2.
The 'status' option is ok for port 2.

[root@vsvr1 ~]# fence_apc -a 192.168.50.21 -l apc -p apc -n 2 -o off -v

Traceback (most recent call last):

 File "/sbin/fence_apc", line 829, in ?

   main()

 File "/sbin/fence_apc", line 303, in main

   do_power_off(sock)

 File "/sbin/fence_apc", line 813, in do_power_off

   x = do_power_switch(sock, "off")

 File "/sbin/fence_apc", line 611, in do_power_switch

   result_code, response = power_off(txt + ndbuf)

 File "/sbin/fence_apc", line 817, in power_off

   x = power_switch(buffer, False, "2", "3");

 File "/sbin/fence_apc", line 810, in power_switch

   raise "unknown screen encountered in n" + str(lines) + "n"

unknown screen encountered in

['', '> 2', '', '', '------- Configure Outlet
------------------------------------------------------', '', '    #  State  Ph 
Name                     Pwr On Dly  Pwr Off Dly  Reboot Dur.', '  
--------------------------------------------------------------- -------------',
'    2  ON     1   Outlet 2                 0 sec       0 sec        5 sec', '',
'     1- Outlet Name         : Outlet 2', '     2- Power On Delay(sec) : 0', ' 
   3- Power Off Delay(sec): 0', '     4- Reboot Duration(sec): 5', '     5-
Accept Changes      : ', '', '     ?- Help, <ESC>- Back, <ENTER>- Refresh,
<CTRL-L>- Event Log', '> ']



Power switch's informations are below

       --------------------------------------------------------------------- --
       About System

       Model Number      : AP7921
       Serial Number     : ZA0735002068
       NMC Serial Number : ZA0735000219
       Manufacture Date  : 08/28/2007
       Hardware Revision : B2
       MAC Address       : 00 C0 B7 73 E2 DE
       Flash Type        : AMD A29DL322DB

       Press <ENTER> to continue...

       --------------------------------------------------------------------- --
       Module Information

       Description : Rack PDU APP
       --------------------------------------------------------------------- --
       Name        : rpdu              Type        : StatApp
       Version     : 333               Sector      : 16
       Date        : 01/05/2007        Time        : 14:56:33
       CRC16       : B79D

       Press <ENTER> to continue...

       Description : Network Management Card AOS
       --------------------------------------------------------------------- --
       Name        : aos               Type        : APC OS
       Version     : 334               Sector      : 47
       Date        : 01/05/2007        Time        : 14:23:44
       CRC16       : 2D13

Version-Release number of selected component (if applicable):
cman-2.0.73-1

How reproducible:
# fence_apc -a 192.168.50.21 -l apc -p apc -n 2 -o off -v


Steps to Reproduce:
1.
2.
3.
  
Actual results:
# fence_apc -a 192.168.50.21 -l apc -p apc -n 2 -o off -v
<snip>
   raise "unknown screen encountered in n" + str(lines) + "n"

unknown screen encountered in
<snip>

Expected results:
# fence_apc -a 192.168.50.21 -l apc -p apc -n 6 -o off -v
Status check successful. Port 6 is OFF
Power Off successful


Additional info:
Comment 1 Shih-Hsin Yang 2007-11-26 12:47:08 EST
Created attachment 269121 [details]
The /tmp/apclog for power off port 2, port off port 6
Comment 2 Wade Mealing 2007-11-29 02:19:48 EST
This is a dupe of  #396581
Comment 3 Wade Mealing 2007-11-29 02:20:44 EST

*** This bug has been marked as a duplicate of 396581 ***

Note You need to log in before you can comment on or make changes to this bug.