Bug 400431 - --udi option disables or enables all tests
--udi option disables or enables all tests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
: 401721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 20:13 EST by Greg Nichols
Modified: 2008-05-01 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 10:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2007-11-26 20:13:27 EST
Description of problem:

The --udi option when used with the "hts plan --enable" or "hts plan --disable"
command disables/enables all tests.

HTS 5.1 Version R13
Comment 1 Greg Nichols 2007-11-26 20:34:58 EST
Fixed R14
Comment 2 Greg Nichols 2007-11-27 15:47:25 EST
*** Bug 401721 has been marked as a duplicate of this bug. ***
Comment 3 Shengliang Lv 2007-11-27 19:34:14 EST
When will we get R14?
Comment 5 Satyabrata Maitra 2007-12-18 06:20:59 EST
Hi Greg
I tried this option for hts-5.1-18.el5 on i386.
Tried command hts plan --uid --enable or --disable.
Is it the right command to execute? bcoz, with --disable option, the test still
run, as I observed with the command hts certify --test core.

Please inform the exact test steps and command to follow step by step, if possible.
When this command to execute, after creating plans, or later? pls inform.
Comment 6 Satyabrata Maitra 2007-12-18 06:24:17 EST
sorry typo mistake - --uid/--udi in above comment.

And by the way..
What is the argument to pass after --udi option? Pls inform
Comment 7 Greg Nichols 2007-12-18 09:31:30 EST
1) The --test option will override any disabled tests.

2) To test the --disable option, first, disable some tests, then  run "hts
certify" to verify that the disabled tests are not run.

3) The value of the --udi parameter should be the UDI of the device with the
test to be disabled.  These can be seen in the output of "hts print --report plan".
Comment 8 Satyabrata Maitra 2007-12-19 04:45:46 EST
Tested this bug on i386 arch with RHEL5.1-Server.

This bug is Fixed in the proposed version of hts. 
Step Followed :-
1. disable a particular test with the command : hts plan --disable --test
network --udi eth0
2. hts certify

This command disabled the network test. Other planned tests run as usual. Verified.

Version of the component tested :-
hts-5.1-18.el5

Greg, Thanks for your URLs. :)

Note You need to log in before you can comment on or make changes to this bug.