Bug 400741 - glibc's fcntl2 open redirects seem to be wrong for alpha
glibc's fcntl2 open redirects seem to be wrong for alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
8
alpha Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 06:19 EST by Oliver Falk
Modified: 2008-08-13 05:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 05:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-11-27 06:19:21 EST
gcc -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mieee -o
.libs/ifo_dump ifo_dump.o  ../dvdread/.libs/libdvdread.so -ldl
../dvdread/.libs/libdvdread.so: undefined reference to `__open64_2'
collect2: ld returned 1 exit status
make[2]: *** [ifo_dump] Error 1
make[2]: Leaving directory `/home/oliver/cvs/F-8/libdvdread/libdvdread-0.9.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/oliver/cvs/F-8/libdvdread/libdvdread-0.9.7'
make: *** [all] Error 2


[oliver@gosa libdvdread-0.9.7]$ rpm -qf /usr/include/bits/fcntl2.h
glibc-headers-2.6.90-21
Comment 1 Jakub Jelinek 2007-11-27 10:43:43 EST
You either need to kill the open64 line in
sysdeps/unix/sysv/linux/alpha/syscalls.list, or add
sysdeps/unix/sysv/linux/alpha/open64_2.c and copy there code from
.../linux/open64.c and add it to ../linux/alpha/Makefile.
Comment 2 Oliver Falk 2007-12-03 03:41:11 EST
Jakub. Since you're glibc packager. Can you provide the fix/patch? Or do you
think it might be better to get the new glibc 2.7 running first? And/or can you
provide the fix for 2.7?
Comment 3 Ulrich Drepper 2008-07-29 02:22:59 EDT
Retest this with the current rawhide code.

Note You need to log in before you can comment on or make changes to this bug.