Bug 401221 - stopping ntpd crashes domU
stopping ntpd crashes domU
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 11:06 EST by David L. Parsley
Modified: 2009-02-13 10:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 10:49:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. Parsley 2007-11-27 11:06:45 EST
Description of problem:
After running ntpd in a domU for some time (after a week or so), 'service ntpd
stop' crashes the domU kernel.

Version-Release number of selected component (if applicable):
domU:
[root@itfederation ~]# uname -r
2.6.18-53.el5xen
[root@itfederation ~]# rpm -q ntp
ntp-4.2.2p1-7.el5

dom0:
[root@lnxvmhost4 ~]# uname -r
2.6.18-53.el5xen


How reproducible:
Very; it's happened to me 5-6 times on VMs with uptimes > a couple weeks.

Steps to Reproduce:
1. Install a RHEL5 VM w/ ntpd running; don't modify independent_wallclock
2. Wait a few weeks (don't really know how long, but I've not had this problem
on VMs w/ uptimes of only 10-40 minutes)
3. Issue 'service ntp stop'
  
Actual results:
Kernel panic

Expected results:
ntp stops gracefully

Additional info:
ntp is running on dom0.  I've modified our build scripts not to run ntpd on
VMs, since it's unneeded when dom0 runs it.  However, when I went to stop ntp
on a couple of non-critical (fortunately) VM servers today, they both panicked.
 I will try to reproduce this on a test VM and attach the panic output, but I
want to wait a week to be confident it'll happen.
Comment 1 Daniel Berrange 2008-07-09 08:32:07 EDT
I can't reproduce this problem. If you can still reproduce it on latest RHEL-5.2
kernels, then capture a kernel panic log and attach it to this ticket.

You can easily capture kernel panics by editing /etc/sysconfig/xend and setting
XENCONSOLED_LOG_GUESTS=yes, and then rebooting the host. After this all guest
console output is loged to /var/log/xen/console/guest-NAME.log
Comment 2 Bill Burns 2009-02-13 10:49:44 EST
Closing this ticket as it was not reproducible and the reported has not responded to the needinfo request for over 6 months. Please reopen is it can be reproduces of you can provide some detail.

Note You need to log in before you can comment on or make changes to this bug.