Bug 40124 - problems with lilo after install of red hat 7.1. Boot loader in partition past 1024 cyl.
problems with lilo after install of red hat 7.1. Boot loader in partition pas...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-10 15:25 EDT by Thierry O. Fischmann
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-07 16:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry O. Fischmann 2001-05-10 15:25:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Computer DELL Latitude C600 laptop with 20GB HD. First partition is NTFS
win2000. Size: 4 GB. Win2000 boot loader in MBR. ext2 Linux /hda2=/boot
(23333KB) and /hda5=/ (remaining) partitions follows. Upgrade from RH7.0 to
7.1 or fresh install of 7.1. Selected "linear" in lilo. At end of install
installer stated that lba32 is the correct choice (there is no lba32
button, but un-selecting "linear" does just this: bad dialog design see bug
14351 and related). Then could not boot linux from win2000 boot loader.
Tried to modify lilo configuration but failed. 1: attempt to boot from
/boot using rescue floppy fails: message about partitions unproperly
unmounted and needing verifying. 2: Could see partition when booting from
RH 7.1 CD binary 1 / linux rescue. Verified the partitions from there.
Still same problem as before. CD's bought shrink-wrap (not downloaded).
Problem disappear when un-selecting "linear" during installation.

How reproducible:
Always

Steps to Reproduce:
0.Dell latitude laptop with cd-rom in bay only: attach floppy drive to
parallel port to allow creation of emergency boot disk (likely unimportant
to reproduce the bug if you have already such a floppy or an internal
floppy drive but that's how it happened on my machine).
1.Win2k in first partition exceeding 1024 cyl & Win2k boot loader in MBR to
start lilo (not sure it's important) /boot in partition past 1024 cyl
(essential).
2.Install RH7.1 from cd's select linear in lilo configuration
3.Try to boot new installation.
4.Try to use emergency boot disk.
5.Try to use boot from RH7.1 binary 1 and verify partitions.
6.Install RH7.1 (re-format /boot and / partitions) un-selecting "linear" in
lilo configuration.
	

Actual Results:  2. => installer at end of install complains that lba32
should be used
3 => lilo failure
4 => fails msg about checking the partitions
5 => still can't boot same msg as before (or maybe I missed something...)
6 => works but old data lost

Expected Results:  I wish that the program will have used lba32 by default
(ide) linear for scsi
I wish i would have been able to recover partition (but maybe that was
possible and I missed something. In which case I wish there was a HOW-To
about this.

Additional info:
Comment 1 Brent Fox 2001-05-21 09:22:35 EDT
We don't have this hardware, so I can't really reproduce it.  I'm trying to
understand exactly what the problem is...
Is the problem that selecting 'linear' in the LILO screen causes the system to
be unbootable?
Comment 2 Thierry O. Fischmann 2001-05-21 10:08:13 EDT
The fact to select "linear" in the LILO screen indeed causes the system to be 
unbootable.
In addition when selecting "linear" in the LILO screen the installation program 
gives a warning that lba32 should have been used.
Comment 3 Brent Fox 2001-07-06 09:30:55 EDT
Are things ok if you don't select 'linear'?
Comment 4 Thierry O. Fischmann 2001-07-06 10:33:35 EDT
Everything is ok when linear is not selected. That's how I've solved this 
issue, and the laptop has run very reliably since then.
Comment 5 Brent Fox 2001-07-07 16:49:23 EDT
Ok.  We've made some changes to the bootloader that should avoid this problem in
the future.

Note You need to log in before you can comment on or make changes to this bug.