Bug 401461 - Quake3 wont run.
Quake3 wont run.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 12:29 EST by Alexey Kuznetsov
Modified: 2007-12-10 15:13 EST (History)
0 users

See Also:
Fixed In Version: f8-20071210
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 15:08:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2007-11-27 12:29:26 EST
Description of problem:
when i try run quake3 my quake 3 stuck.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-33.fc8
quake-1.32b
mesa-libGL-7.0.1-7.fc8

kernel-module-ATI-fglrx-2.6.23.1-49.fc8-8.433-1.f8
ATI-fglrx-control-center-8.433-1.f8
ATI-fglrx-8.433-1.f8


Additional info:

Opening IP socket: localhost:27964
Hostname: axet-laptop.local
Alias: axet-laptop
Alias: localhost.localdomain
Alias: localhost
Alias: axet-laptop
IP: 127.0.0.1
Started tty console (use +set ttycon 0 to disable)
^5PunkBuster Client: PunkBuster Client (v0.993 | A0) **DISABLED**
^3PunkBuster Server: PunkBuster Server (v0.993 | A0 C0.0) **DISABLED**
quake3.x86: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Received signal 1, exiting...
Shutdown tty console
Comment 1 Matěj Cepl 2007-11-27 17:57:09 EST
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).
Comment 2 Alexey Kuznetsov 2007-12-10 07:12:44 EST
same problem with opensource radeonhd driver.
Comment 3 Alexey Kuznetsov 2007-12-10 07:18:22 EST
radeonhd dont have 2d, and 3d acceleration. But i make test with opengl java
application, i think that is correct.

if u try to run opengl application u got

java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

looklike x-server problem
Comment 4 Alexey Kuznetsov 2007-12-10 15:08:16 EST
radeonhd for fine for me now.

Note You need to log in before you can comment on or make changes to this bug.