This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 401611 - FEAT: web/html reporting of test results
FEAT: web/html reporting of test results
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 13:47 EST by Greg Nichols
Modified: 2008-05-01 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 10:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2007-11-27 13:47:51 EST
Description of problem:

HTS should provide test results reporting in html form.  Since HTS already
requires httpd and python on the system under test, test results could be served
via httpd, allowing results to be viewed remotely.
Comment 1 Greg Nichols 2007-11-27 13:49:18 EST
A rudimentary version of this feature is provided in R14.
Comment 2 Satyabrata Maitra 2007-12-18 04:00:37 EST
Hi Greg

How to test it? what are the test steps to follow? Can it be tested remotely and
on any RHEL5.1-Server desktop? Please inform.
Satya
Comment 3 Greg Nichols 2007-12-18 09:25:59 EST
1) Run some tests with hts 

2) With SELinux set to Enforcing, you will need to correct the security context via:

chcon -R -t httpd_sys_content_t/var/hts

3) Start the hts server on the system under test with "hts server start",
or start the web server directly with "service httpd start"

4) Test results should be visible via http://<server ip or hostname>/hts/

  
Comment 4 Satyabrata Maitra 2007-12-19 06:25:33 EST
Tested this bug on ia64 arch with RHEl5.1-Server.

This bug is fixed. Its showing the test results on web via http.

All the environment setup with SELinux Enforcing done before run the test. And
the result is as proposed showing.

Note You need to log in before you can comment on or make changes to this bug.