Bug 401721 - "hts plan --disable" doesn't work as expect
"hts plan --disable" doesn't work as expect
Status: CLOSED DUPLICATE of bug 400431
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 15:17 EST by Shengliang Lv
Modified: 2007-11-27 15:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 15:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shengliang Lv 2007-11-27 15:17:35 EST
Description of problem:
When I want to use "hts plan --disble" to disable some test suites, "--udi" 
or "--device" doesn't work as expect, for example, in my system:

# hts print
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
cdrom      scd0       storage_serial__NEC_DVD__RW_ND_6650A_A60020000001
usb
network    eth1       net_00_15_60_04_e9_d9
network    eth0       net_00_15_60_04_e9_d8
memory
core
video                 pci_1002_5159
storage    cciss/c0d0 pci_103c_3220_0
storage    cciss/c1d0 pci_103c_3220
info

When I run "hts plan --disable --udi pci_103c_3220_0" to disable cciss/c1d0, 
hts disable all the test suites:

[root@max1-pr hts]# hts plan --disable --udi pci_103c_3220_0
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
Disabled 94 tests
saved test plan to /var/hts/plan.xml
[root@max1-pr hts]# hts print
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
cdrom      scd0       storage_serial__NEC_DVD__RW_ND_6650A_A60020000001  - 
DISABLED
usb                                                         - DISABLED
network    eth1       net_00_15_60_04_e9_d9                 - DISABLED
network    eth0       net_00_15_60_04_e9_d8                 - DISABLED
memory                                                      - DISABLED
core                                                        - DISABLED
video                 pci_1002_5159                         - DISABLED
storage    cciss/c0d0 pci_103c_3220_0                       - DISABLED
storage    cciss/c1d0 pci_103c_3220                         - DISABLED
info

Version-Release number of selected component (if applicable):
Kernel: 2.6.18-53.el5xen
HTS: hts-5.1-13

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Greg Nichols 2007-11-27 15:47:24 EST

*** This bug has been marked as a duplicate of 400431 ***

Note You need to log in before you can comment on or make changes to this bug.