Bug 40188 - header missing as well as order number
header missing as well as order number
Status: CLOSED DEFERRED
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-10 23:33 EDT by Jay Turner
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 11:17:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-05-10 23:33:13 EDT
Description of Problem:
Placing an order for just a service package will result in page without a
header as well as receipt without an order number.

How Reproducible:
always

Steps to Reproduce:
1. Log into http://bmantest.meridian.redhat.com as rhn7_mocha/pink4all
2. Place 10-pack of incident support in the cart
3. Begin the checkout process, continuing til the shipping selection page
4. Notice that parts of the header are missing like the navigation bar and
  the Red Hat logo
5. Click Continue Checkout and finish the order process
6. Notice on the receipt that there is not an order number listed

Actual Results:
Get page without parts of the header, and then get receipt without order
number.


Expected Results:
Shipping selection screen should have complete header and receipt should
have valid order number.

Additional Information:
Comment 1 Cameron Prince 2001-05-11 01:30:28 EDT
Due to environment issues with webdevel, we had to work on the receipt pages on 
bmantest then copy them to webdevel for the RPM build. I think you ran into 
this while we were working. I can't reproduce now.
Comment 2 Jay Turner 2001-05-11 15:55:45 EDT
I am getting it with any order that I push through which does not have a
shipping cost.  Still getting it today (5/11) on bmantest.meridian with service
packages as well as RHN subscriptions.
Comment 3 Jay Turner 2001-05-11 15:58:17 EDT
Actually, I will ammend this a little.  I just tried it again with Netscape and
I get the header on the shipping screen, but still don't get the order number. 
Not getting either when running mozilla (latest daily build)
Comment 4 Jay Turner 2001-05-11 15:59:09 EDT
Also, just got a confirmation email from the order . . . shows null for the
order number.
Comment 5 Cameron Prince 2001-05-17 15:15:20 EDT
Should be fixed now. Just placed a test RHN order (W2198585) with no problems.
Comment 6 Jay Turner 2001-05-17 15:22:32 EDT
This is fixed on webdevel.redhat.com.  Closing out the bug.
Comment 7 Jay Turner 2001-06-01 22:27:30 EDT
The 'missing order number' situation is back on
http://www.webqa.redhat.com/cgi-bin/store for service package orders.
Comment 8 Cameron Prince 2001-06-07 11:17:42 EDT
Fixed on webdevel and bmantest.
Comment 9 Jay Turner 2001-09-18 09:00:25 EDT
Closing this out as Interchange did not launch.

Note You need to log in before you can comment on or make changes to this bug.