Bug 401901 - g-p-manager doesn't see any bt phones running as user
g-p-manager doesn't see any bt phones running as user
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-phone-manager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 17:10 EST by Radek Vokal
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 18:05:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vokal 2007-11-27 17:10:12 EST
Description of problem:
I've just updated from FC6 to F8. The gnome-phone-manager doesn't see any
bluetooth device running as a user, I can only connect to my phone starting
g-p-manager as root. Bluetooth manager can see my phone without any problems.

Version-Release number of selected component (if applicable):
gnome-phone-manager-0.40-1.fc8

How reproducible:
always

Additional info:
Let me know what I can provide.
Comment 1 Bastien Nocera 2007-11-27 17:25:15 EST
(In reply to comment #0)
> Description of problem:
> I've just updated from FC6 to F8. The gnome-phone-manager doesn't see any
> bluetooth device running as a user, I can only connect to my phone starting
> g-p-manager as root. Bluetooth manager can see my phone without any problems.

Which version of libbtctl and gnome-bluetooth are you using? See any errors
stracing gnome-phone-manager? Does "hcitool search" work? Do yo have multiple
Bluetooth adapters?
Comment 2 Radek Vokal 2007-11-27 17:47:51 EST
libbtctl-0.9.0-3.fc8
gnome-bluetooth-0.9.1-3.fc8

I'm using Dell d620 with the built-in bluetooth
radek@localhost ~$ hcitool scan
Scanning ...
        00:1B:AF:26:9D:52       Nokia 6120 radek

and here I see the problem. Searching for a bluetooth device returns at least 10
blank options, so my phone is listed somewhere down on the list. Sorry I haven't
seen the scrollbar first. The output is 

radek@localhost ~$ gnome-phone-manager 
** Message: bdaddr 
** Message: New connection device is empty (not changed)
** Message: New connection device is empty (not changed)
** Message: No device!
** Message: Exiting connect thread
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: Already know about 00:1B:AF:26:9D:52, preparing for rediscovery
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: Auto-retrying the connection
** Message: New connection device is empty (not changed)
** Message: New connection device is empty (not changed)
** Message: No device!
** Message: Exiting connect thread
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry_result_with_rssi:   bdaddr 00:1B:AF:26:9D:52 class 5a020c
** Message: inquiry complete
** Message: device 00:1B:AF:26:9D:52 Nokia 6120 radek found
** Message: Auto-retrying the connection
** Message: New connection device is 00:1B:AF:26:9D:52 (changed)
** Message: New connection device is 00:1B:AF:26:9D:52 (not changed)

I'd say, not a bug .. just a cosmetic issue :)
Comment 3 Bastien Nocera 2007-11-27 18:05:45 EST
Right, UI-wise it sucks. Should get fixed in the future:
http://bugzilla.gnome.org/show_bug.cgi?id=455838

Note You need to log in before you can comment on or make changes to this bug.