Bug 402081 - USB scanner not accepting address
USB scanner not accepting address
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 20:39 EST by Barry Stewart
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 21:51:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Stewart 2007-11-27 20:39:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
When I plug in my Epson Perfection 1650 USB scanner, /var/log/messages reports that:

usb 2-8: new full speed USB device using ohci_hcd and address 28
usb 2-8: device descriptor read/64, error -62
usb 2-8: device descriptor read/64, error -62
usb 2-8: new full speed USB device using ohci_hcd and address 29
usb 2-8: device descriptor read/64, error -62
usb 2-8: device descriptor read/64, error -62
usb 2-8: new full speed USB device using ohci_hcd and address 30
usb 2-8: device not accepting address 30, error -62
usb 2-8: new full speed USB device using ohci_hcd and address 31
usb 2-8: device not accepting address 31, error -62

I run "Applications -> Graphics -> Scanner Tool" but it reports "no device available".

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8

How reproducible:
Always


Steps to Reproduce:
1.  Plug in your Epson Perfection 1650 USB scanner
2.  Watch /var/log/messages
3.  Try to use the scanner tool

Actual Results:
Scanner tool reports "no device available" 

Expected Results:
Scanner tool finds my scanner and works like it did in F7.

Additional info:
This kernel mailing list discussion may be relevant, I dunno...

http://lkml.org/lkml/2007/9/14/302
Comment 1 Pete Zaitcev 2007-11-28 01:19:14 EST
I think this is different from the thread at l-k, because there isn't a -71
anywhere. It's just the scanner not replying at all. I think it's either the
mobo's USB controller is dead of the scanner itself. I would try to find out
by plugging the scanner elsewhere and finding another 12 mbit/s device to
plug into the box (aka "full speed"). Note that the "high speed" devices
like storage are handled by a different controller even when plugged into
the same socket, so that's no use for testing.
Comment 2 Barry Stewart 2007-11-28 21:51:22 EST
OK, my scanner seems to be working now.  All I did was a yum update and reboot.
 None of the updated packages seemed relevant to the kernel or USB, though. 
Sorry for the false alarm.

Note You need to log in before you can comment on or make changes to this bug.