Bug 40225 - bash: no job control in this shell
Summary: bash: no job control in this shell
Status: CLOSED DUPLICATE of bug 36839
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bash (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-11 12:09 UTC by Olivier Baudron
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 16:48:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2001-05-11 12:09:30 UTC
This is probably not a bash bug, but I could not figure out where it comes
from. The problem is: when I "su" in a virtual console I get the message
"bash: no job control in this shell", and it is true that next I cannot
interrupt processes. Surprinsingly, this bug is not present if I "su" in an
xterm running under X.
On my system, almost all packages are up-to-date with the latest rawhide
releases.

Comment 1 Bernhard Rosenkraenzer 2001-05-11 20:22:49 UTC
Yet another effect of a broken /bin/login (#36839)

*** This bug has been marked as a duplicate of 36839 ***

Comment 2 Olivier Baudron 2001-05-11 20:42:18 UTC
Thanks a lot for your advice and for the link to the latest util-linux.
I spent the whole day inside bash/termcap/readline/ncurses and was about to
become crazy!!!

Btw, another effect of this bug was that the virtual console is broken by emacs
when quitting.

Anyway, thanks again ;)))

Comment 3 Bernhard Rosenkraenzer 2001-05-11 20:44:50 UTC
THAT effect is a feature, of course. #include <vi/forever.h> ;) SCNR


Note You need to log in before you can comment on or make changes to this bug.