Bug 402471 - IcedTea makes X-Server crash with some java applets
IcedTea makes X-Server crash with some java applets
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 05:01 EST by Pitam
Modified: 2007-12-02 18:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-02 18:47:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pitam 2007-11-28 05:01:28 EST
Iced Tea makes X-Server crash while handling some java applets.

Steps to reproduce: 

Install icedtea via yum, and install icedtea-java plugin

# yum install java-*-icedtea-plugin
# yum install java-*-icedtea java-*-icedtea-devel

now navigate to this page using firefox 2.0.0.9

http://www.java.com/en/download/help/testvm.xml
Comment 1 Christopher Aillon 2007-11-28 09:24:13 EST
This is probably an icedtea problem...
Comment 2 Lillian Angel 2007-11-28 16:02:23 EST
I tested this out and it works file. What version of IcedTea are you using?

I have this version installed (from rawhide):
java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9
Comment 3 Pitam 2007-11-30 23:59:18 EST
I have this version:

java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8
Comment 4 Pitam 2007-12-01 00:04:04 EST
How did u get this version? java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9

I am using yum to update ... in fedora 8. yum says the latest version is already
installed. Maybe we should update the yum repository then? (and point to the
version you are using)
Comment 5 Pitam 2007-12-01 03:21:12 EST
Upgrading to firefox 2.0.0.11 fixes the problem....
Comment 6 Lillian Angel 2007-12-02 18:47:04 EST
You can get the version by doing: rpm -qf java-1.7.0-icedtea

icedtea-b23 can be installed from rawhide (yum --enablerepo=development update java-1.7.0-icedtea)

Closing this bug since it is fixed with the firefox update.

Note You need to log in before you can comment on or make changes to this bug.