Bug 40287 - Add an option not to animate images
Summary: Add an option not to animate images
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-11 19:47 UTC by Trond Eivind Glomsrxd
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 06:29:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2001-05-11 19:47:34 UTC
It would be very nice if Mozilla could be made not to animate images -
animated gifs can be very distracting, and just showing the first frame
would be a very welcome option - MSIE on Mac(not Win) and Opera already
have this functionality, AFAIK

Comment 1 Christopher Blizzard 2001-05-15 22:07:48 UTC
This is already documented in the release notes for mozilla.  However, I don't
know if it's in 0.7 or not.  It's in more recent releases as a hidden pref.

Comment 2 Trond Eivind Glomsrxd 2001-05-15 22:35:58 UTC
Where? And can it be made not hidden?

Comment 3 Aleksey Nogin 2001-05-16 06:29:46 UTC
See http://bugzilla.mozilla.org/show_bug.cgi?id=17686 ,
http://bugzilla.mozilla.org/show_bug.cgi?id=19258 and
http://bugzilla.mozilla.org/show_bug.cgi?id=74169

To summarize, the way you control animation is by putting 
user_pref("image.animation_mode", "once");
or
user_pref("image.animation_mode", "none");
into your prefs file, but in some versions of Mozilla this would not work.



Comment 4 Christopher Blizzard 2001-06-09 22:01:05 UTC
Not a bug.


Note You need to log in before you can comment on or make changes to this bug.