Bug 402921 - formatting message - performance issue
formatting message - performance issue
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 10:05 EST by markm
Modified: 2008-03-16 17:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 17:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 361145 None None None Never

  None (edit)
Description markm 2007-11-28 10:05:33 EST
Description of problem:

when you have images, attachments in your email, it takes ages to render the
email. it also creates a high cpu usage and hungs application for a while

Version-Release number of selected component (if applicable):

evolution 2.12.1-3.fc8

How reproducible:

always, if message has two or more attachments

Steps to Reproduce:
1. Create a message with 160 business cards
2. Send it
3. Go to Sent folder
4. Click on that message...
  
Actual results:

application is not responding for around 10 minutes, creating high cpu usage

Expected results:

if rendering a message takes that long, allow to click anywhere else and that
should break rendering process - if I have that big message in my outbox, I can
accidentally open it when I don't want, but it causes me to wait 10 minutes to
have my application back on track. 

Additional info:

Computer is Core 2 Duo T7500 intel with Nvidia graphics card, I guess it's quite
fast platform to have an email rendered quickly ;)
Comment 1 Matthew Barnes 2007-11-28 10:52:31 EST
(In reply to comment #0)
> Steps to Reproduce:
> 1. Create a message with 160 business cards

Can you please attach such a message that causes the performance issue?
Comment 2 markm 2007-11-28 11:07:04 EST
Sure, with 160 contacts directly to the internet? I am sure, my collogues,
friends and family would be happy when they find it out that I've posted their
contacts on the internet :)

I will create fake business cards and check if that message cause a problem, if
yes, I will attach it.
Comment 3 Russell Harrison 2008-02-19 15:44:53 EST
I'm also seeing this problem with evolution 2.12.3

Other bugs which may be duplicates of this one are:
http://bugzilla.gnome.org/show_bug.cgi?id=361145
http://bugzilla.gnome.org/show_bug.cgi?id=342910
http://bugzilla.gnome.org/show_bug.cgi?id=502665

Seems to be a fairly common problem.

$ rpm -qa | grep evolution
evolution-exchange-2.12.3-1.fc8
evolution-exchange-debuginfo-2.12.3-1.fc8
evolution-data-server-1.12.3-2.fc8
evolution-remove-duplicates-0.0.3-1.fc8
evolution-sharp-debuginfo-0.14.0.1-1.fc8
libopensync-plugin-evolution2-0.22-2.fc8
evolution-remove-duplicates-debuginfo-0.0.3-1.fc8
evolution-2.12.3-1.fc8
evolution-webcal-2.12.0-1.fc8
evolution-help-2.12.3-1.fc8
evolution-data-server-debuginfo-1.12.3-2.fc8
syncevolution-0.6-2.fc8
evolution-sharp-0.14.0.1-1.fc8
libopensync-plugin-evolution2-debuginfo-0.22-2.fc8
evolution-python-0.0.4-2.fc8
evolution-python-debuginfo-0.0.4-2.fc8
evolution-webcal-debuginfo-2.12.0-1.fc8
evolution-debuginfo-2.12.3-1.fc8
beagle-evolution-0.2.18-5.fc8
Comment 4 Matthew Barnes 2008-03-16 17:58:03 EDT
Consolidating these reports to one bug.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=361145

Note You need to log in before you can comment on or make changes to this bug.