Bug 403271 - FileCopyException
FileCopyException
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 13:45 EST by Steve Chapel
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 17:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Chapel 2007-11-28 13:45:25 EST
Description of problem:
When I tried to install Rocks Cluster Distribution 4.3, I got the following
message (copied by hand):
An unhandled exception has occurred. This is most likely a bug. Please copy the
full text of this exception and file a detailed bug report against anaconda at
http://bugzilla.redhat.com/bugzilla/
Traceback (most recent call last):
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/gui.py", line 1074, in
handleRenderCallback
  self.currentWindow.renderCallback()
File "/tmp/updates/usr/lib/anaconda/progress_gui.py", line 249 in renderCallback
  self.intf.icw.nextClicked()
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/gui.py", line 789, in
nextClicked
  self.dispatch.gotoNext()
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/dispatch.py", line 171, in
gotoNext
  self.moveStep
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/dispatch.py", line 239, in
moveStep
  rc = apply(func, self.bindArgs(args))
File "/tmp/ksclass.py", line 1414, in RocksPreInstall
File "/tmp/ksclass.py", line 1409, in RocksReadComps
File "/tmp/updates/usr/lib/anaconda/packages.py", line 172, in readPackages,
  grpset = method.readComps(hdrlist)
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/installMethod.py", line 65,
in readComps
  return self.readCompsViaMethod(hdlist)
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/urlinstall.py", line 96, in
readCompsViaMethod
  return groupSetFromCompsFile(fname, hdlist)
File "/var/tmp/anaconda-10.1.1.63//usr/lib/anaconda/hdrlist.py", line 937, in
groupSetFromCompsFile
  raise FileCopyException
NameError: global net 'FileCopyException' is not defined

Version-Release number of selected component (if applicable):
10.1.1.63

How reproducible:
Always, on my Dell PowerEdge 1950

Steps to Reproduce:
1. Install Rocks 4.3 on my Dell PowerEdge 1950
  
Actual results:
The above error.

Expected results:
Rocks installs.

Additional info:
It's possible that I get the FileCopyException because the DVD image is bad.
Even if so, it looks like FileCopyException is used without being defined, so
it's still an anaconda bug.
Comment 1 Chris Lumens 2007-11-28 17:09:06 EST
This is fixed in the next stable release of RHEL.  If you require this fix
backported to RHEL4, please speak to your support representative who will raise
this issue through the appropriate channels.  This will allow us to target the
fix for the proper update release.

Note You need to log in before you can comment on or make changes to this bug.