Bug 403281 - RTNL: assertion failed at net/core/dev.c when entering/leaving promiscuous mode
RTNL: assertion failed at net/core/dev.c when entering/leaving promiscuous mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 14:00 EST by Bertil Askelid
Modified: 2007-12-07 16:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 16:03:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bertil Askelid 2007-11-28 14:00:22 EST
Description of problem:

When a VMware client is started or stopped, promiscuous mode is changed for the 
ethernet interface /dev/eth0 used to access the Internet. This causes the
following traceback from the kernel due to a failed assertion:

Nov 28 09:46:36 z kernel: RTNL: assertion failed at net/core/dev.c (2595)
Nov 28 09:46:36 z kernel:  [<c05bb422>] __dev_set_promiscuity+0x3f/0x115
Nov 28 09:46:36 z kernel:  [<c04b20a7>] proc_register+0xcf/0xf0
Nov 28 09:46:36 z kernel:  [<c04b2136>] create_proc_entry+0x6e/0x81
Nov 28 09:46:36 z kernel:  [<c05bb6ee>] dev_set_promiscuity+0x10/0x24
Nov 28 09:46:36 z kernel:  [<f8f09798>] VNetBridgeStartPromisc+0x22/0x41 [vmnet]
Nov 28 09:46:36 z kernel:  [<f8f08515>] VNetHubPortsChanged+0x8e/0x9d [vmnet]
Nov 28 09:46:36 z kernel:  [<f8f0757a>] VNetConnect+0x8a/0x8f [vmnet]
Nov 28 09:46:36 z kernel:  [<f8f07eab>] VNetFileOpOpen+0xc0/0x149 [vmnet]
Nov 28 09:46:36 z kernel:  [<c0483742>] chrdev_open+0x111/0x14e
Nov 28 09:46:36 z kernel:  [<c0483631>] chrdev_open+0x0/0x14e
Nov 28 09:46:36 z kernel:  [<c047f9f5>] __dentry_open+0xd5/0x18c
Nov 28 09:46:36 z kernel:  [<c047fb26>] nameidata_to_filp+0x24/0x33
Nov 28 09:46:36 z kernel:  [<c047fb6c>] do_filp_open+0x37/0x3e
Nov 28 09:46:36 z kernel:  [<c047f8a6>] get_unused_fd_flags+0x52/0xc5
Nov 28 09:46:36 z kernel:  [<c047fbbb>] do_sys_open+0x48/0xca
Nov 28 09:46:36 z kernel:  [<c047fc76>] sys_open+0x1c/0x1e
Nov 28 09:46:36 z kernel:  [<c040518a>] syscall_call+0x7/0xb
Nov 28 09:46:36 z kernel:  =======================
Nov 28 09:46:36 z kernel: device eth0 entered promiscuous mode
Nov 28 09:46:36 z kernel: bridge-eth0: enabled promiscuous mode


Version-Release number of selected component (if applicable):

kernel-2.6.23.1-49.fc8

How reproducible:

Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2007-12-07 16:03:43 EST
Looks like a bug in the vmware network driver.

Note You need to log in before you can comment on or make changes to this bug.