Bug 403311 - init_crypto doesn't say which device's passphrase it's prompting for
init_crypto doesn't say which device's passphrase it's prompting for
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 14:09 EST by David Lehman
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: cryptsetup-1.0.6-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 11:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Minimal effort approach to making clear which device's passphrase we are asking for (469 bytes, patch)
2007-11-28 14:14 EST, David Lehman
no flags Details | Diff

  None (edit)
Description David Lehman 2007-11-28 14:09:09 EST
Description of problem:
A system with multiple encrypted devices can end up with multiple passphrase
prompts during bootup. It can be very frustrating when you don't know which
device's passphrase you're being prompted for.

Version-Release number of selected component (if applicable):
initscripts-8.60-1

How reproducible:
Always

Steps to Reproduce:
1. set up multiple encrypted devices
2. populate /etc/crypttab appropriately
3. boot
  
Actual results:
You are presented with "Enter LUKS passphrase:" prompt for each device in
crypttab, but it is not clear which device is being opened. This will be
particularly troublesome on the first boot after installation when users have no
idea what the ordering of entries in crypttab is.

Expected results:
Some indicator of which device is being opened so the user can know which
passphrase to enter.

Additional info:
This would be maddening enough with passwords, but with potentially lengthy
passphrases this can be a real pain.
Comment 1 David Lehman 2007-11-28 14:14:00 EST
Created attachment 271631 [details]
Minimal effort approach to making clear which device's passphrase we are asking for

This is sort of a minimalist approach for illustrative purposes. Still, better
than nothing.
Comment 2 Bug Zapper 2008-05-14 00:03:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alexander Todorov 2008-07-09 08:15:58 EDT
Works for me, F9 stock install asks:
Enter LUKS passphrase for /dev/sda2:

on my laptop.

Note You need to log in before you can comment on or make changes to this bug.