Bug 40399 - RFE: add memory_cs module
RFE: add memory_cs module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-13 13:29 EDT by Gerald Teschl
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-05-13 13:29:28 EDT
Description of Problem:


How Reproducible:

Please include the pcmcia memory_cs module. I know most users won't
need it, but I just tried to get an unsupported card to work and
this would have saved me quite some time.
Comment 1 Arjan van de Ven 2001-05-15 13:43:23 EDT
Do you actually have a memory_cs card?
I'm asking this as I'm prepared to port the driver, but cannot test it as
I don't have any hardware for it.
Comment 2 Gerald Teschl 2001-05-16 12:36:47 EDT
Does it actually drive any cards? I just used it to get a memory dump of my
network card.
There are some instruction on the PCMCIA-HOWTO on how to get an unsupported
ne2000 compatible card working. In particular, the instructions say to use this
driver to
get a memory dump and search for the mac address of the card.

I downloaded the latest pcmcia source and compiled only the memory_cs module,
worked
fine. However, I couldn't find the mac addr. of the card in the memory dump;-(
Comment 3 Richard Smith 2002-09-23 10:33:41 EDT
I have some PCMCIA SRAM cards to which I would like to write.

I installed kernel-pcmcia-cs-3.1.27-18.src.rpm, and compiled the standard parts
with:

rpm -bc kernel-pcmcia-cs.spec

My thought then was to cd to clients/ and 'make memory_cs.o'.  This failed with
the following errors:

gcc   -MD -O3 -Wall -Wstrict-prototypes -pipe -I../include/static
-I/usr/src/linux-2.4/include -I../include  -D__KERNEL__ -DMODULE -c memory_cs.c
In file included from ../include/static/linux/module.h:5,
                 from ../include/pcmcia/k_compat.h:92,
                 from memory_cs.c:40:
/usr/src/linux-2.4/include/linux/module.h:299: parse error before `UTS_RELEASE'
In file included from /usr/src/linux-2.4/include/linux/rwsem.h:29,
                 from /usr/src/linux-2.4/include/asm/semaphore.h:42,
                 from /usr/src/linux-2.4/include/linux/fs.h:200,
                 from /usr/src/linux-2.4/include/linux/capability.h:17,
                 from /usr/src/linux-2.4/include/linux/binfmts.h:5,
                 from /usr/src/linux-2.4/include/linux/sched.h:9,
                 from /usr/src/linux-2.4/include/asm/uaccess.h:8,
                 from ../include/static/asm/uaccess.h:49,
                 from ../include/pcmcia/k_compat.h:191,
                 from memory_cs.c:40:
/usr/src/linux-2.4/include/asm/rwsem.h: In function
`__down_write_trylock_R3e2a6822':
/usr/src/linux-2.4/include/asm/rwsem.h:176: warning: implicit declaration of
function `cmpxchg'
In file included from memory_cs.c:46:
/usr/src/linux-2.4/include/linux/malloc.h:4:2: warning: #warning linux/malloc.h
is deprecated, use linux/slab.h instead.
make: *** [memory_cs.o] Error 1

Obviously, something about my approach is not right!

I have tried this on two different machines.  One has the
kernel-source-2.4.18-10 rpm installed, the other has kernel-source-2.4.18-5. 
Both produce the same results.

If you could provide the appropriate runes, I would be happy to test the
memory_cs.o module.
Comment 4 Michael Selway 2003-01-30 05:48:13 EST
I have a memory card which I used to use all the time.  Since upgrading to rh7.3
it hasn't worked, I guess because memory_cs is missing.  The card is listed in
/etc/pcmcia/config as "Franklink/Rolodex REX-3000".  I'd really like to see this
working again.  I've tried building memory_cs.o as described above, I had the
same problems.  Also doesn't work in rh8.0.
Comment 5 Peter E. Popovich 2003-02-28 16:42:00 EST
i'm experiencing the same problems with kernel 2.4.18-24.8.0. since i'm using a
intel-based centennial linear flash card, i'll need ftl_cs.o too.

it appears this bug has been open for quite a while. can someone at redhat shed
light on when (or even if) someone will be working on this?
Comment 6 Pavel Roskin 2003-03-09 17:21:05 EST
memory_cs exists in pcmcia-cs, but not in the kernel.  The kernel uses 
pcmciamtd driver: http://www.si.org/pcmciamtd/. I tried it with
2.4.21-pre4-ac7 - it works. Unfortunately, the mem_type option has to be
set to 1, otherwise the driver is looking for CFI and JEDEC chips. Also,
I had to set force_size, despite the fact that memory_cs from pcmcia-cs
3.2.3 has no problems determining the size. It's also required to load
mtdblock or mtdchar modules to be able to access the card as a block or 
a character device. The kernel driver needs some work to make it
smarter. Being a PCMCIA driver, it has all the information about the 
card and can be changed to determine memory type and size, just like
memory_cs. Anyway, it should be possible to compile MTD in the kernel,
replace memory_cs with pcmciamtd in /etc/pcmcia/config, add dependency
on mtdblock (also can be done in /etc/pcmcia/config) and set mem_type to
1 (RAM). It's possible that the size of other cards will be
autodetected. Even if it's not, the only thing to be done by the user 
would be setting module parameters, as opposed to compiling MTD drivers.
My card is MagicRAM MR002SRV34PI (the one that's used with OpenAP).
Comment 7 David Woodhouse 2003-03-10 03:14:25 EST
pcmciamtd.c is part of Marcelo's 2.4 kernel since 2.4.21-pre4.
I agree we should probably enable and ship it.
Comment 8 Bugzilla owner 2004-09-30 11:38:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.