Bug 404541 - application freeze when trying to send email
application freeze when trying to send email
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 10:09 EST by markm
Modified: 2008-01-15 13:08 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-2.12.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 13:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2007-11-29 10:09:51 EST
Description of problem:

Basically spam test are taking too long and making application freeze for couple
of minutes! But when I accidentally press 'send' button while evolution is
receiving new emails, it freezes and I need to kill application.

Version-Release number of selected component (if applicable):

latest from fedora.download.com

How reproducible:

always

Steps to Reproduce:
1. write email
2. send it while application is receiving something in the background
  
Actual results:

application freeze and email is lost (after restart of course it allows me to
recover an email, but... recovered email doesn't have my text, I've typed).

Expected results:

working smoothly... without freezes and hangs - it's really annoying.

Additional info:
Comment 1 Milan Crha 2007-11-29 13:50:23 EST
Can you install debug info packages of evolution, evolution-data-server and
gtkhtml (and evolution-exchange, if you use exchange) and when it freezes,
attach gdb to the process and attach here result of command "thread apply all
bt", please? We will see where it get stuck. Thanks in advance.
Comment 2 Matthew Barnes 2007-11-29 14:07:35 EST
Also, which spam filtering plugin are you using -- SpamAssassin or Bogofilter?

If SpamAssassin, it turns out the behavior for the "Include remote tests" option
is inverted -- it runs remote tests if the option is UNCHECKED.  Remote tests
make spam filtering more accurate but can really slow things down.

I fixed this upstream just recently but it hasn't trickled down yet.
Comment 3 markm 2008-01-15 09:32:10 EST
I believe it's fixed in current release as it works fine for me now.
Thanks.
Comment 4 Matthew Barnes 2008-01-15 13:08:58 EST
Thanks for the update.  Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.