Bug 40458 - pump fails to renew its lease
pump fails to renew its lease
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-13 22:08 EDT by Seth Vidal
Modified: 2007-03-26 23:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 09:19:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pump's logs at debug level (6.85 KB, text/plain)
2001-05-15 16:52 EDT, Seth Vidal
no flags Details

  None (edit)
Description Seth Vidal 2001-05-13 22:08:38 EDT
Description of Problem:
pump fails to renew its lease. It will get it the first time and the system
will work just fine but then it will die at the first automatic renewal.
The dhcp server is a rhl 6.2 which works nicely with 6.2 and 7.0 boxes.


How Reproducible:
I can cause it to occur every night. However I've logged daemon.debug and
not gotten any information from pump - it just dies.

The only cards I've tried this on is 3com 3c905c's - but I've tried two
different cards (same model though) - I'll see if I can come up with
another card type.


Steps to Reproduce:
1. run pump until a renewal and it should lose its address at the first renewal


Additional Information:
dhcpcd works just fine. But I like the additional features the pump.conf
provides for my systems.
Comment 1 Seth Vidal 2001-05-15 09:18:55 EDT
I've tested this problem with 3 different nics now (1 netgear fa310-tx(pnic) and
2 3com 3c905c's)

It will lose the ip after about 12 hours.

I'm going to try the same test with the pump from 7.0 next.

Has anyone seen any problems like this recently?
Comment 2 Seth Vidal 2001-05-15 10:41:02 EDT
Ok I've confirmed that the lease is given up after the max-lease-time value is
expired (I set the default-lease-time to 600 and max-lease-time to 900) - the
nic stopped having an ip 15minutes afterwards.

I'm going to try pump from 7.0 now.

Comment 3 Seth Vidal 2001-05-15 11:10:10 EDT
I've tried pump from rh 7.0 and it still has the same problem.

It seems like it could be something in the network config scripts that run after
pump renews its lease.
I'm going to look around in there now.

is anyone reading this? and/or have a suggestion on where to look?

Comment 4 Olivier Baudron 2001-05-15 12:16:51 EDT
To obtain debugging information make sure you have in /etc/syslog.conf something
like: daemon.* /var/log/daemon
Then restart the logging daemon: /etc/rc.d/init.d/syslog restart
Also, what is your pump version?
Comment 5 Seth Vidal 2001-05-15 12:22:54 EDT
pump 0.8.11-1 from 7.1 and 0.8.3-2 from 7.0

and I've got daemon.debug set to pump.log

as far as I can tell its not pump but its something from initscripts that pump
is calling after it renews.

I'm working on that now.

Comment 6 Seth Vidal 2001-05-15 15:39:55 EDT
I've changed the priority on this one b/c I can get it to happen EVERYTIME now.

I've gone through and added some debug checks into ifup-post and I can't figure
out where it is happening in there.

can someone tell me what the ordering is for what runs when pump gets a renewal?

-sv
Comment 7 Olivier Baudron 2001-05-15 15:44:09 EDT
What is your initscripts version?
Comment 8 Seth Vidal 2001-05-15 15:47:08 EDT
current with 7.1 (5.83-1)

-sv
Comment 9 Olivier Baudron 2001-05-15 16:08:04 EDT
I am really curious how pump can die in this manner.
Can you post the log messages of pump at renewal?
Comment 10 Seth Vidal 2001-05-15 16:51:00 EDT
There are no log messages at renewal.
I've watched the logs for a long time and I've gotten NOTHING from them.

pump is still running after it loses its address.
but I don't get anything new in the logs.

I'll attach the logs 
Comment 11 Seth Vidal 2001-05-15 16:52:18 EDT
Created attachment 18510 [details]
pump's logs at debug level
Comment 12 Olivier Baudron 2001-05-15 17:29:27 EDT
In cannot see any request lease time in your log. Can you check that "pump -s"
shows the right renewal time? Also, after you loose your IP adress, what
information do you have with "ifconfig eth0" ?
Comment 13 Seth Vidal 2001-05-15 17:34:11 EDT
The device is still up - but no line which reads:
Inet: 192.168.182.16 etc etc etc

it just vanishes.
pump -s reports that:

renewal time is 100 seconds from the lease time.
the expiration time is 200seconds away from the lease time.
Comment 14 Seth Vidal 2001-05-15 17:36:35 EDT
after pump fails to get the address back pump -s does reports:
Operation Failed.

so clearly something is unhappy.

:)

Comment 15 Olivier Baudron 2001-05-15 17:50:49 EDT
What is amazing is that you don't have any log messages from pump when renewing
(it should display a dozen of lines for each message between client and server).
Can you see the messages with "tcpdump"? Also, the server should have sent a 600
seconds lease time (not 200s), or did I miss something?
Comment 16 Seth Vidal 2001-05-15 21:26:50 EDT
I changed the max-lease-time to 200s - the default-lease-time to 100s (I didn't
want to wait as long to see it break :)

I'll check a tcpdump tomorrow.



Comment 17 Olivier Baudron 2001-05-15 22:06:49 EDT
In your logs, the server proposes a lease time of 6 seconds, and next 12 seconds
(after the client requested for lot much). Did you really set these values in
the dhcp server config? Otherwise, there may be a timing problem there...
Comment 18 Seth Vidal 2001-05-15 22:11:17 EDT
where in the logs does it say that


the pertinent section of the dhcpd.conf file:
host wks-test {
        hardware ethernet <stuff here>;
 	fixed-address 192.168.182.16;
	next-server install.domain.com;
        server-identifier install.domain.com;
        filename "/export/install/linux/rh-7.1/ks/workstation";
        option domain-name "phy.duke.edu";
        default-lease-time 100; 
	max-lease-time 200;
}
Comment 19 Olivier Baudron 2001-05-15 22:17:10 EDT
bresp: vendor:  51   4 0x00 0x00 0x00 0xc
It means that the server proposes a 12 sec lease.
See: http://www.dhcp.org/rfc2132.html par. 9.2
Comment 20 Seth Vidal 2001-05-15 22:30:53 EDT
odd - pump -s lists the time as being greater than 12 seconds.

so if its getting that from the server (which I will check in the leases file
tomorrow) then its not interepreting it correctly.

and why would this machine work perfectly with dhcpcd?
Comment 21 Olivier Baudron 2001-05-15 22:39:37 EDT
Can you give me exactly what is shown by "pump -s" ?
Comment 22 Seth Vidal 2001-05-15 22:45:24 EDT
I can send you pump -s output tomorrow.

a possibility just hit me though.

this line in the dhcpd.conf file

next-server install.domain.com;

install.domain.com != the dhcpd server.
in the past next-server was needed for ks to look for a different place for its
ks.cfg over nfs.

could it be that next-server is now being listened to?
I've noticed some weird requests being blocked by the ipchains on the machine
that is install.domain.com.

Comment 23 Seth Vidal 2001-05-15 22:48:17 EDT
ok I retract that.

its not next-server

its almost definitely server-identifier
which I think was being ignored by pump before this.

Comment 24 Seth Vidal 2001-05-16 09:19:18 EDT
Ok its working now - it was server-identifier.

which makes sense considering what it means.

however, should pump have just started obeying it?

I'm going to close this bug but I think its worth noting



Note You need to log in before you can comment on or make changes to this bug.