Bug 404641 - there is no x86_64 libX11-devel
there is no x86_64 libX11-devel
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-29 10:47 EST by Joseph Shraibman
Modified: 2008-09-09 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-09 16:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2007-11-29 10:47:57 EST
Description of problem:
When I try to build atscap, the build fails with:
/usr/bin/ld: skipping incompatible /usr/lib/libX11.so when searching for -lX11
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make: *** [xtscut] Error 1

There is no /usr/lib64/libX11.so

Version-Release number of selected component (if applicable):

How reproducible:
All the time

Steps to Reproduce:
1. download atscap from atscap.sf.net
2. untar it
3. run make
Actual results:
/usr/bin/ld: skipping incompatible /usr/lib/libX11.so when searching for -lX11
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make: *** [xtscut] Error 1

Expected results:

Additional info:
This was not a problem in Fedora Core 5, so this is a regression.
Comment 1 Matěj Cepl 2007-11-30 04:39:05 EST
First, I would suggest to add to your ~/.rpmmacros this line

%_query_all_fmt     %%{name}-%%{version}-%%{release}.%%{arch}

I expect that the problem is in missing x86_64 package. When I do on my computer
(as root):

yum whatprovides /usr/lib64/libX11.so

I get

libX11-devel.x86_64 : X.Org X11 libX11 development package
libX11-devel.x86_64 : X.Org X11 libX11 development package

What is the output of command

yum list installed libX11-devel

Comment 2 Joseph Shraibman 2007-12-01 18:05:32 EST
Installed Packages
libX11-devel.i386                        1.1.3-4.fc8            installed 

When I tried "yum install libX11-devel.x86_64" it worked.  The reason I filed
this bug is because when I went looking for libX11-devel 64 bit version in yumex
it only listed the i386 version.  Any idea why that was?
Comment 3 Matěj Cepl 2007-12-04 17:12:46 EST
OK, then it is probably some problem with yumex, right? Reassigning.
Comment 4 Tim Lauridsen 2008-07-25 06:20:20 EDT
Joseph, can you confirm that yumex only show libX11-devel.i386 and not
in the current version of yum and yumex.
Comment 5 Joseph Shraibman 2008-07-25 11:02:57 EDT
Right now on my Fedora 8 install it is showing both, but I have them both
installed.  I don't have a Fedora 9 box right now.
Comment 6 Jan Hutař 2008-09-09 02:38:09 EDT
I have uninstalled that package and tired to find them using yumex and was successful:

Package View -> Packages: Available -> libX11-devel <Enter>

Can you please try this:

# rpm -e --nodeps libX11-devel.x86_64 libX11-devel.i386
# yumex   # try to reproduce the problem
Comment 7 Joseph Shraibman 2008-09-09 11:08:10 EDT
I just tried that and both packages were listed in yumex.
Comment 8 Matěj Cepl 2008-09-09 16:11:22 EDT
thanks for letting us know

Note You need to log in before you can comment on or make changes to this bug.