This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 404721 - segfault when trying to open a non existing device
segfault when trying to open a non existing device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 12:16 EST by Milan Broz
Modified: 2013-02-28 23:06 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.0.6-0.1.pre2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 17:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2007-11-29 12:16:20 EST
Cryptsetup segfaults if called for non-existent device

# cryptsetup luksOpen /dev/bla test
Segmentation fault

cryptsetup-luks-1.0.5-7

Simple patch already in devel svn, or here
http://article.gmane.org/gmane.linux.kernel.device-mapper.dm-crypt/2218
Comment 1 Till Maas 2008-01-11 14:44:18 EST
Thanks for reporting this. This happens also in F8, but it does not in F7. I do
not really know why. Nevetheless, I guess it would be enough to fix this in
rawhide. I plan to maybe upgrade rawhide to cryptsetup 1.0.6 pre, afaik it
mainly contains useful patches from debian, but I try it first on my notebook.
Then this would be fixed, too.
Comment 2 Milan Broz 2008-01-21 11:19:42 EST
Till, there are other serious cryptsetup problems in rawhide (my test scripts
sometimes left temporary dm-crypt mapping etc.)
(Another debian patch "run udevsettle after dm device creation").

These patches should be backported asap or we should switch to 1.0.6 pre.

(Please let me know if you need help with testing or fixing these bugs.)

(btw bug is apparently even in F7 but because some compiler optimization it
works :-)
Comment 3 Till Maas 2008-01-21 12:12:38 EST
(In reply to comment #2)
> Till, there are other serious cryptsetup problems in rawhide (my test scripts
> sometimes left temporary dm-crypt mapping etc.)

Could I have access to your test scripts?

> These patches should be backported asap or we should switch to 1.0.6 pre.
> 
> (Please let me know if you need help with testing or fixing these bugs.)

It would be great when you could test cryptsetup 1.0.6 pre1, e.g. these rpms:
http://koji.fedoraproject.org/koji/taskinfo?taskID=362539
Comment 4 Till Maas 2008-01-21 17:34:52 EST
There is a bug in debian:
http://bugs.debian.org/460409

Cryptsetup 1.0.6 pre1 does not support adding keys to an opened luks partition
anymore.
Comment 5 Till Maas 2008-03-03 17:07:25 EST
Rawhide does now contain cryptsetup 1.0.6 pre2. Nevertheless I am still
interested in the test scripts. :-)

Note You need to log in before you can comment on or make changes to this bug.