Bug 405341 - ppc32 kexec-tools no longer understands 64-bit kernels
ppc32 kexec-tools no longer understands 64-bit kernels
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
8
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 22:43 EST by David Woodhouse
Modified: 2008-02-29 05:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.102pre-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-11-29 22:43:00 EST
[root@ps3 boot]# kexec -f --command-line="root=/dev/VolGroup00/LogVol00
video=720p panic=30" --initrd=initrd-2.6.23.1-43.fc8.img vmlinuz-2.6.23.1-43.fc8 
Cannot determine the file type of vmlinuz-2.6.23.1-43.fc8
Comment 1 Kazunori Asayama 2008-02-28 01:34:19 EST
Even if I used F8's ppc64 kexec-tools, 64 bit kernels couldn't be loaded onto
PLAYSTATION 3.

[root@localhost boot]# kexec -l --initrd=/boot/initrd-2.6.23.15-137.fc8.img
--append=root=LABEL=/ /boot/vmlinuz-2.6.23.15-137.fc8
get memory ranges:0
Could not find a free area of memory of 775000 bytes...
Base address: ffffffff is not page aligned

I used kexec-tools-1.1.02pre-4.fc8.ppc64.rpm

I also tried the original kexec-tools
(git://git.kernel.org/pub/scm/linux/kernel/git/horms/kexec-tools-testing.git)
built for ppc64 and it worked well, so this problem seems to be specific to Fedora.
Comment 2 Neil Horman 2008-02-28 07:32:41 EST
David, do you happen to know the last kernel that F8 kexec-tools-1.102pre-4
worked with?

Also, is this a general 64 bit kernel issue, or is it specific to cell?
Comment 3 Kazunori Asayama 2008-02-28 09:30:59 EST
(In reply to comment #2)
> Also, is this a general 64 bit kernel issue, or is it specific to cell?

I tried the same thing on Mac G5 and it was OK, so my problem is not ppc64-generic.

I find that I tried kexec on a recent ps3-linux.git kernel, not a F8 kernel.
I'll try the same thing on the F8 kernel/PS3 tomorrow (sorry... I have no access
to PS3 right now).
Comment 4 David Woodhouse 2008-02-28 10:35:05 EST
(In reply to comment #2)
> David, do you happen to know the last kernel that F8 kexec-tools-1.102pre-4
> worked with?

It's not a kernel issue, is it? We used to carry a patch which made the 32-bit
kexec userspace tools capable of booting a 64-bit kernel. Now we don't.
Comment 5 Neil Horman 2008-02-28 10:48:40 EST
Ahh, I thought that was already integrated into the upstream tree.  Come to
think of it, why isn't it integrated?  I'll patch it in of course, but can you
post it to the kexec-list?  Or would you rather I did that?
Comment 6 Fedora Update System 2008-02-28 13:54:49 EST
kexec-tools-1.102pre-5.fc8 has been submitted as an update for Fedora 8
Comment 7 David Woodhouse 2008-02-28 15:58:42 EST
kexec-list? I believe I created that some time _after_ I created said patch :)

I think it has been merged upstream now, hasn't it?
Comment 8 Fedora Update System 2008-02-28 16:36:51 EST
kexec-tools-1.102pre-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Kazunori Asayama 2008-02-29 05:18:12 EST
(In reply to comment #8)
> kexec-tools-1.102pre-5.fc8 has been pushed to the Fedora 8 stable repository.
 If problems still persist, please make note of it in this bug report.

Same results. On PS3, it doesn't work.

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 16:40:13 EST
2008 ppc64 ppc64 ppc64 GNU/Linux

I tried the following versions:

[root@localhost ~]# kexec -l --initrd=/boot/initrd-2.6.23.15-137.fc8.img
--append=root=/dev/VolGroup00/LogVol00 /boot/vmlinuz-2.6.23.15-137.fc8

* kexec-tools-1.102pre-4.ppc64:
* kexec-tools-1.102pre-5.ppc64:

  get memory ranges:0
  Could not find a free area of memory of 775000 bytes...
  Base address: ffffffff is not page aligned

* kexec-tools-1.102pre-5.ppc:

  Cannot determine the file type of /boot/vmlinuz-2.6.23.15-137.fc8

* kexec-tools-testing.git (32 bit binary, 64 bit kernel)
* kexec-tools-testing.git (64 bit binary, 64 bit kernel)

  OK.

Note You need to log in before you can comment on or make changes to this bug.