Bug 405391 - Problem whith included LAM/MPI (FC8)
Problem whith included LAM/MPI (FC8)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 23:54 EST by Dmitrij S. Kryzhevich
Modified: 2008-07-30 18:34 EDT (History)
0 users

See Also:
Fixed In Version: 7.1.4-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitrij S. Kryzhevich 2007-11-29 23:54:53 EST
LAM/MPI 7.1.2-10 (included in F8 from F7, as I saw)
Compiled whith LAM/MPI code, includding examples from off. site, does not work 
in multithread form. I think, it's version problem as far package was not 
rebuilt for F8. New version of package for RHEL4 from off. site while installed 
on F8 work whithout errors.
Comment 1 Doug Ledford 2008-06-25 14:49:10 EDT
Rebuilt and updated at the same time.
Comment 2 Fedora Update System 2008-06-25 15:00:33 EDT
lam-7.1.4-1.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-06-26 04:29:05 EDT
lam-7.1.4-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lam'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5726
Comment 4 Fedora Update System 2008-07-23 03:03:52 EDT
lam-7.1.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Dmitrij S. Kryzhevich 2008-07-30 05:47:02 EDT
/usr/lib/lam/bin/mpirun
/usr/lib/lam/bin/lamboot

Is following path is correct?
Comment 6 Doug Ledford 2008-07-30 18:34:04 EDT
Yes.  It is intended for you to use the environment-modules package to select
lam for your default MPI implementation if that's the one you wish to use.  Once
you have the environment-modules package installed, doing something like adding
this:

module load /usr/lib/lam/lam.module

to any user's .bash_profile (or other personal shell startup script) will be
sufficient to get the proper paths you need added to their environment setup.

Note You need to log in before you can comment on or make changes to this bug.