Bug 405541 - error convert DICOM
Summary: error convert DICOM
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ImageMagick   
(Show other bugs)
Version: 5.0
Hardware: x86_64 Linux
low
low
Target Milestone: ---
: ---
Assignee: Jan Horak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-30 08:19 UTC by Andrey
Modified: 2015-04-27 11:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 11:40:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrey 2007-11-30 08:19:34 UTC
Description of problem:
only x86_64 platform and convert DICOM get 'Insufficient image data in file'

Version-Release number of selected component (if applicable):
ImageMagick-6.2.8.0-3.el5.4

How reproducible:
convert -verbose test.dcm test.jpg

Steps to Reproduce:
1. use x86_64 platform
2. convert -verbose test.dcm test.jpg

Actual results:


Expected results:


Additional info:
in x86_64 platform:
convert: Insufficient image data in file `test.dcm'.
convert: missing an image filename `test.jpg'.
0x01AA 4294967295 SQ- (0x0008,0x1140) Referenced Image Sequence

same in i386 platform:
0x01AA 0 SQ- (0x0008,0x1140) Referenced Image Sequence: -1
good result.

possible correct patch:
[code]
--- a/coders/dcm.c      2007-11-30 16:04:46.000000000 +0800
+++ b/coders/dcm.c      2007-11-30 15:56:10.000000000 +0800
@@ -2850,7 +2850,7 @@
         quantum=1;
       else
         quantum=8;
-      if (datum != -1)
+      if (datum != 0xFFFFFFFF)
         length=(size_t) datum/quantum;
       else
         {
[/code]

Comment 2 RHEL Product and Program Management 2014-03-07 13:55:17 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Product and Program Management 2014-06-03 11:40:02 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.