Bug 40561 - Kernal module cipcb is not unloaded after ifdown
Summary: Kernal module cipcb is not unloaded after ifdown
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cipe (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-14 16:21 UTC by Martin C. Messer
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-22 16:51:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin C. Messer 2001-05-14 16:21:04 UTC
Description of Problem:

'ifdown cipcb0' does not remove the cipcb module from memory, which causes
problems if one executes 'ifup cipcb0' before the module cleaner (rmmod
-as) is run.

How Reproducible:

Only if you ifdown and ifup before the module cleaner runs.

Steps to Reproduce:
1.  ifup cipcb0 
2.  ifdown cipcb0
3.  lsmod
4.  ifup cipcb0  

Actual Results:

Step 3 shows cipcb loaded but not used and ready for autoclean.
Step 4, if ran before autocleaning, either errors with 'resource busy', or
doesn't error but cipe then acts eradically.

Expected Results:

Can cipe clean it's own module?

Additional Information:

Comment 1 Scott Schmit 2001-07-11 21:52:37 UTC
This isn't a bug. The bug is that cipcb has to be rmmod'd at all. It worked in
wolverine, but broke since then. After all, we don't do this with ethX, etc...


Note You need to log in before you can comment on or make changes to this bug.