Bug 405751 - Oracle-instant client depends on compat-libstdc++-33
Oracle-instant client depends on compat-libstdc++-33
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Justin Sherrill
:
Depends On:
Blocks: 309031 410261
  Show dependency treegraph
 
Reported: 2007-11-30 05:29 EST by Miroslav Suchý
Modified: 2008-04-02 16:52 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2007-11-30 05:29:21 EST
Description of problem:
Oracle-instant client depends on compat-libstdc++-33. It not in @base, therefore
it should be added by sat installer.

Version-Release number of selected component (if applicable):
510

How reproducible:
done once

Steps to Reproduce:
1. install latest sat from iso with oracle-instantclient
  
Actual results:
Dependencies should have already been resolved, but they are not.
Unresolved rpm dependencies:

Package oracle-instantclient-basic  10.2.0.3-2.el4 requires libstdc++.so.5
Package oracle-instantclient-basic  10.2.0.3-2.el4 requires
libstdc++.so.5(CXXABI_1.2)
Package oracle-instantclient-basic  10.2.0.3-2.el4 requires
libstdc++.so.5(GLIBCPP_3.2)
Comment 1 Michael Mráka 2007-12-11 10:00:10 EST
Oracle-instantclient is installed within bootstrap packages. So adding compat-
libstdc++-33 into updates/rhelrpms doesn't help - these are installed later.

Either copy RHEL's  compat-libstdc++-33 to bootstrap or modify bootstrap 
installation procedure so it also installs prereqs.
something similar to 
$ rpm -qp --requires bootstrap/*rpm|sort -u | sed 's/^\(.*\)$/--
solvedeps="\1"/;' | xargs up2date 
Comment 2 Michael Mráka 2007-12-13 06:39:57 EST
compat-libstdc++-33 added into bootstrap.

revision 1.1
date: 2007/12/13 09:48:01;  author: mmraka;  state: Exp;
Comment 3 Michael Mráka 2007-12-13 07:28:58 EST
testplan:
./install.pl should not fail before it comes to 'up2date -i' stage
Comment 4 Justin Sherrill 2008-01-03 11:09:36 EST
Seems to work ok for me.  After I installed the -31 iso, these packages were
installed without error:

oracle-instantclient-basic-10.2.0-6
oracle-instantclient-jdbc-10.2.0-6
oracle-instantclient-config-10.2.0-6
oracle-instantclient-sqlplus-10.2.0-6
Comment 5 Justin Sherrill 2008-01-03 12:58:21 EST
Actually this bug is still present for the s390 -32 build.  Moving to failsQA.
Comment 6 Jan Pazdziora 2008-01-11 07:06:47 EST
Taking this bug for the x390(x) part as I have it on my table ATM.
Comment 7 Jan Pazdziora 2008-01-11 07:09:56 EST
Checking in
bootstrap-redhat-linux-as-s390-4/compat-libstdc++-33-3.2.3-47.3.s390.rpm;
/cvs/rhn/rhn/satellite/bootstrap-redhat-linux-as-s390-4/compat-libstdc++-33-3.2.3-47.3.s390.rpm,v
 <--  compat-libstdc++-33-3.2.3-47.3.s390.rpm
initial revision: 1.1

Checking in
bootstrap-redhat-linux-as-s390x-4/compat-libstdc++-33-3.2.3-47.3.s390x.rpm;
/cvs/rhn/rhn/satellite/bootstrap-redhat-linux-as-s390x-4/compat-libstdc++-33-3.2.3-47.3.s390x.rpm,v
 <--  compat-libstdc++-33-3.2.3-47.3.s390x.rpm
initial revision: 1.1
Comment 8 Jan Pazdziora 2008-01-14 07:29:22 EST
Satellite 5.1.0-47 and Proxy 5.1.0-20 Content now available on webqa
Channels.

Satellite 5.1.0-47 ISOs are now available as
rhn-satellite-5.1.0-47-redhat-linux-as-* @:

http://barn.rhndev.redhat.com/satellite-isos/devel/satellite-5.1/

Moving to ON_QA.
Comment 9 Shannon Hughes 2008-03-26 11:16:37 EDT
looks ok on 10-64
Comment 10 Brandon Perkins 2008-04-02 16:52:16 EDT
64Bit-Satellite/Proxy on x86_64 RHEL for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.