Bug 405991 - --XX:MaxPermSize argument doesn't make it to the VM
Summary: --XX:MaxPermSize argument doesn't make it to the VM
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-30 15:39 UTC by Mary Ellen Foster
Modified: 2008-05-01 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 16:43:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mary Ellen Foster 2007-11-30 15:39:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):
I've been having repeated problems with Eclipse crashing because it runs out of
PermGen space. The default /usr/share/eclipse/eclipse.ini file includes a line
intended to increase the PermGen space, and this argument is definitely making
it to Eclipse (now that I've temporarily copied the file to /usr/lib/eclipse,
see bug 394161) -- I can see in the eclipse.vmargs it if I go to Help - About
and click "Configuration Details".

However, I don't think that the Java VM is actually changing its behaviour in
any way based on this argument. If I monitor the PermGen usage with jstat (jstat
-gcpermcapacity -t -h30 <pid> 5000 prints the values every 5 seconds), I can see
that the PGCMX value is always 65536.0 and the PGC value increases as I work
with Eclipse until it sticks at 65536.0, and then Eclipse generally crashes.

How reproducible:
Every time

Steps to Reproduce:
1. Run Eclipse with -vmargs --XX:MaxPermSize=128m (as in the default eclipse.ini)
2. Run jstat -gcpermcapacity and look at the value for PGCMX
  
Actual results:
PGCMX is 65536.0

Expected results:
PGCMX should be 131072.0 (or thereabouts)

Comment 1 Mary Ellen Foster 2007-11-30 15:40:39 UTC
Oops, the version of IcedTea is java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9

Comment 2 Andrew Overholt 2008-05-01 16:12:24 UTC
I have this in my eclipse.ini:

-XX:MaxPermSize=128m

and I have java-1.6.0-openjdk-1.6.0.0-0.10.b09.fc9 installed.  Running the jstat
command you posted, I get this value every 5 seconds:

PGCMX
131072.0

Comment 3 Mary Ellen Foster 2008-05-01 16:43:00 UTC
Yes, sorry, I guess this bug probably went away a while ago. I haven't seen
PermGen-type crashes for a while now. I'll close this.


Note You need to log in before you can comment on or make changes to this bug.