Bug 406021 - RFE: provide backup of logical volumes on all cluster nodes after activation/deactivation
Summary: RFE: provide backup of logical volumes on all cluster nodes after activation/...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: lvm2-cluster (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 393271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-30 16:01 UTC by Corey Marthaler
Modified: 2010-01-12 04:06 UTC (History)
7 users (show)

Fixed In Version: RHBA-2008-0806
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 19:26:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0806 normal SHIPPED_LIVE lvm2-cluster bug fix and enhancement update 2008-07-25 19:26:14 UTC

Description Corey Marthaler 2007-11-30 16:01:44 UTC
Description of problem:
Currently in clvm, a backup is made only on the node which does the operation.
Since this is a clustered volume manager, a back up should really be made on all
nodes incase the metadata gets corrupted and the volume needs to be restored.
One can currently work around this by creating the extra backups by hand.

Version-Release number of selected component (if applicable):
2.6.9-67.ELlargesmp
lvm2-2.02.27-4.el4
lvm2-cluster-2.02.27-4.el4

Comment 3 Christine Caulfield 2007-12-04 15:42:43 UTC
I've added code to locking & clvmd so that when a clustered VG lock is removed,
the remote clvmds are told to take a metadata backup if the backups are out of
date. The remote copies will be tagged with a command of "clvmd" rather than the
lvm command that initiated the change.

/cvs/lvm2/LVM2/WHATS_NEW,v  <--  WHATS_NEW
new revision: 1.741; previous revision: 1.740
done
Checking in daemons/clvmd/clvm.h;
/cvs/lvm2/LVM2/daemons/clvmd/clvm.h,v  <--  clvm.h
new revision: 1.6; previous revision: 1.5
done
Checking in daemons/clvmd/clvmd-command.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd-command.c,v  <--  clvmd-command.c
new revision: 1.19; previous revision: 1.18
done
Checking in daemons/clvmd/lvm-functions.c;
/cvs/lvm2/LVM2/daemons/clvmd/lvm-functions.c,v  <--  lvm-functions.c
new revision: 1.36; previous revision: 1.35
done
Checking in daemons/clvmd/lvm-functions.h;
/cvs/lvm2/LVM2/daemons/clvmd/lvm-functions.h,v  <--  lvm-functions.h
new revision: 1.6; previous revision: 1.5
done
Checking in lib/locking/cluster_locking.c;
/cvs/lvm2/LVM2/lib/locking/cluster_locking.c,v  <--  cluster_locking.c
new revision: 1.23; previous revision: 1.22
done


Comment 5 RHEL Product and Program Management 2008-04-11 09:18:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Milan Broz 2008-06-02 15:00:26 UTC
*** Bug 393271 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2008-07-25 19:26:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0806.html



Note You need to log in before you can comment on or make changes to this bug.