Bug 40654 - gated segfaults when starting
gated segfaults when starting
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: gated (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 05:49 EDT by Tarhon-Onu Victor
Modified: 2007-04-18 12:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tarhon-Onu Victor 2001-05-15 05:49:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux
2.2.19-BlackBlueF2L-freeswan-1.8 i686)

Description of problem:
gated-3.6-10 shipped with RedHat-7.1 simply crashes with SIGSEGV before
doing anything. Rebuilding the package does not solve the problem, no
matter what kernel I use: 2.2.19 + patches or 2.4.x (2.4.2-2 + its kernel
headers, from the distro).

How reproducible:
Always

Steps to Reproduce:
1. edit yout gated.conf file
2. start gated
3. ps auxww | grep gated

	

Actual Results:  No route has been added to the routing table, no nothing.
Even gdc checkconf says the conffile is ok, gated segfaults.

Expected Results:  I expected gated to work, of course. On redhat-7.0, 7.0
beta, 7.1 and rawhide versions resulted due upgrading I still use gated
3.5-11 shipped with redhat 6.2.

Additional info:
Comment 1 Jon Benson 2001-05-16 22:00:42 EDT
I'm seeing a similar problem.  I cloned our firewall (RH 6.1) and upgraded it to
7.1   The plan was to simply swap the ethernet cables with the live box and have
things work.

gated just dies though.

I have had a reply from someone who had posted to a newsgroup stating that the
package is incorrectly compiled with 686 optimizations and when he rebuilt it
from source (minus the appropriate flag) it worked.  I have yet to try this
myself but as my CPU is a PII I guess this could be at issue.
Comment 2 Jon Benson 2001-05-17 04:44:23 EDT
As a followup I recompiled this from the src.rpm and it at least runs now.  I
have to wait until next week when I've scheduled an outage to know if it
actually works fully but I suspect it will.

I tend to think the problem is the way the package was built it was optimized
for the specific platform it was built on but I'm no expert.
Comment 3 Jon Benson 2001-05-31 22:27:36 EDT
Another followup.  Whilst I compiled gated from src on a similar platform to the
one I was trying to run it on, and it initially ran, it still crashes as soon as
it tries to do OSPF.

I plan to go to the trouble of installing a compiler, etc on the cloned firewall
to compile a version specific to it.  Then schedule another outage and try
again.

I would LOVE to hear from RedHat on this.  I can't believe such an important
piece of software is broken and the closest resolution (for a 7.1 beta) seems to
be "won't fix"!!
Comment 4 David Thiede 2001-06-06 13:25:46 EDT
I also have run into the crash bug in Redhat 7.1/gated-3.6. The traceback showed
it is in strcpy.

After poking at rpm a while trying to turn off optimization and setting i386, I
just gave up and tried gated-3.5.11-1.i386.rpm from the Redhat6.2 distribution.
It seems to work so far but haven't spent much time at it.When the rest of the
test dns configuration is complete, then I'll hammer on it.
Comment 5 Tarhon-Onu Victor 2001-06-10 05:19:08 EDT
Well, I downloaded the sourcecode of gated-3.6 from gated.org and compiled it
from the source. It crashes too. Anyway it is the same source as is the src.rpm. 
I compiled it with egcs instead of gcc-2.96, so I didn't need to aply the
gated-3.5.11-rh70.patch, and... the result is the same.
	Maybe the guys from redhat should test the software before including it in a
distribution. Zebra doesn't crash, but it acts weird sometimes: compares metrics
with preferences, after modifying filters it forgets to update the routers to
send or receive, and some others which I will not discuss here.. it's not the
right place.
	In the meantime I'll try to compile gated-3.6 on older redhat distributions (I
hope I have a 6.2 running somewhere doing just routing stuff) to see what's the
problem: glibc, kernel headers (I use only 2.2.19 and 2.4.x), <joke>or the
colors from my /etc/issue* files</joke>.
Comment 6 Jon Benson 2001-06-11 23:16:17 EDT
I did go to the trouble of installing a compiler, etc (13 RPMs) on the firewall
to compile a new binary.  I did so via the spec first which gave a binary that
dumped core.  I then did so manually which gave one that again crashed with an
error related to OSPF.

I'm giving up for now.  I'll probably install gated from RH 6.2 as someone else
said they got that working.  :(
Comment 7 robert 2001-08-15 11:24:59 EDT
Get the same coredump problem with an intel PPro system.

Resolved by rebuilding the gated rpm package on the machine it was to run on
after changing the following:

in /usr/lib/rpm/rpmrc:

change:
optflags: i386 -O2 -march=i386 -mcpu=i686
to:
optflags: i386 -O2 -march=i386 -mcpu=i386

There is probably a neater way of doing this but I needed a router fast.
Comment 8 Bill Nottingham 2006-08-07 13:15:03 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 9 Bill Nottingham 2006-10-18 10:17:57 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.