Bug 406681 - 4.21: Better private/public visibility of specific Bugzilla attributes
4.21: Better private/public visibility of specific Bugzilla attributes
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 12:13 EST by David Lawrence
Modified: 2014-10-12 18:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 00:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2007-11-30 12:13:00 EST
Description:
A special 'public' checkbox (or group) that make the main details of the bug visible to the everyone, even though the bug may belong to one or more private groups (perhaps also hiding the reporter's name).\n The 2-state 'private' checkbox against each comment becomes tri-state

Requester:
Alasdair Kergon
Comment 1 David Lawrence 2007-11-30 12:28:19 EST
A special 'public' checkbox (or group) that make the main details of the bug
visible to the everyone, even though the bug may belong to one or more private
groups (perhaps also hiding the reporter's name).

The 2-state 'private' checkbox against each comment becomes tri-state:
(1) visible only to RH
(2) visible only to RH plus the groups the bug belongs to (and reporter/cclist
if checked)
(3) visible to everyone when the bug is marked 'public' - otherwise same as 2

A 'Visibility' of exactly one of 'Red Hat OR Partner OR Public' would be
selected against each comment.  [Obviously the exact wording is open to debate -
'Groups' rather than 'Partner' for example - or use multiple checkboxes.]
Then it would be possible for many of the bugs that today have to be kept
private because they contain information we only want the reporter/partner
groups/cclist to read to be made visible to everyone and we could still have
comments there restricted to partners & issue tracker.
Comment 2 David Lawrence 2008-08-18 17:11:08 EDT
Voting for future Bugzilla features will be opening soon. Announcement of start date will be posted to the bugzilla-development-list@redhat.com and other broader audience.

Dave
Comment 3 David Lawrence 2010-01-15 12:32:27 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 4 David Lawrence 2010-08-25 17:42:48 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 6 Jeff Fearn 2012-05-30 00:43:56 EDT
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 7 Jeff Fearn 2012-05-30 00:44:26 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 8 Alasdair Kergon 2012-05-30 05:02:42 EDT
Still should be changed IMO
Comment 9 Simon Green 2012-06-19 00:02:42 EDT
(In reply to comment #8)
> Still should be changed IMO

This won't happen. At the core of Bugzilla, a private bug is not viewable if you are not able to see the bug. For us to break this will require the Red Hat Bugzilla team would need to maintain its on security on bug information, and that is not feasable.

Note You need to log in before you can comment on or make changes to this bug.