Bug 407021 - Text mode installer does not allow "Change Drive Order" for Grub install to MBR
Text mode installer does not allow "Change Drive Order" for Grub install to MBR
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 18:27 EST by Chris Rainey
Modified: 2007-12-10 13:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 13:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rainey 2007-11-30 18:27:21 EST
Description of problem:

Text mode installer does allow user to "Change Drive Order" of Grub install to
MBR.  This is problematic if the installation was initiated from a USB stick
using a "diskboot.img" and the installer has identified the USB stick as the
only available device to install at the MBR.  Graphical installer allows for
this.  Text mode installer has numerous uses, is more stable and this is the
_only_ drawback I can identify.


Version-Release number of selected component (if applicable):


How reproducible:  Every time.


Steps to Reproduce:
1.  Initiate installation from a USB stick containing a diskboot.img
2.  Select "Text Mode" installtion
3.  Advance through the installer to the Grub install to MBR stage
  
Actual results:  Installer only offers the the MBR of the USB stick as a target
for installation or the first sector of the root partition.


Expected results:  Need consistency with the graphical installer to allow 
"Change Drive Order" while using the Text Mode Installer.


Additional info:
Comment 1 Jeremy Katz 2007-12-10 13:45:53 EST
There's a number of things which are exposed in the graphical UI which aren't
exposed in the text mode due to limitations in the toolkit used for text mode
and as the interactive text mode install is deprecated and going to be mostly
going away at some point in the future.

Note You need to log in before you can comment on or make changes to this bug.