Bug 407141 - TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line' referenced before assignment
TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line' referen...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-iniparse (Show other bugs)
7
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 20:55 EST by Scott Castaline
Modified: 2008-02-21 07:29 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 07:29:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text file (1.42 KB, text/plain)
2007-11-30 20:55 EST, Scott Castaline
no flags Details

  None (edit)
Description Scott Castaline 2007-11-30 20:55:05 EST
Description of problem: pirut crashes when trying to run the updater.


Version-Release number of selected component (if applicable):


How reproducible: everytime


Steps to Reproduce:
1. menu select Applications->System Tools->Software Updater
2. enter root's password if not root
3. Program crash
  
Actual results: Crashes


Expected results:


Additional info:
Comment 1 Scott Castaline 2007-11-30 20:55:05 EST
Created attachment 274601 [details]
text file
Comment 2 Tim Lauridsen 2007-12-05 06:37:35 EST
what version of python do you use ?

rpm -q python-iniparse

This issue should be fixed in the latest release.
python-iniparse-0.2.2-2.fc8


Comment 3 Scott Castaline 2007-12-27 13:47:57 EST
python-iniparse-0.2.3-3.fc7

Actually I found after several attempts that the error started pointing to a
particular repo file. Since it was not a repo that I needed, (Adobe) I just
deleted it. It has been updating fine since then. I was just holding off to make
sure that it didn't happen again.
Comment 4 Tim Lauridsen 2008-02-21 07:29:52 EST
This issue is fixed in python-iniparse-0.2.3-3.

Note You need to log in before you can comment on or make changes to this bug.