Bug 407191 - Build of multiple packages does not work anymore
Build of multiple packages does not work anymore
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 00:13 EST by Lubomir Kundrak
Modified: 2013-01-09 20:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-01 03:40:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-12-01 00:13:10 EST
Description of problem:

$ setarch i686 mock --arch i686 -r fedora-8-i386
/home/lkundrak/rpmbuild/SRPMS/qc-usb-kmod-0.6.6-1.2.6.23.1_49.fc8.src.rpm
/home/lkundrak/rpmbuild/SRPMS/qc-usb-0.6.6-1.fc8.src.rpm
INFO: mock.py version 0.8.9 starting...
State Changed: init plugins
State Changed: start
State Changed: lock buildroot
State Changed: clean
INFO:
Start(/home/lkundrak/rpmbuild/SRPMS/qc-usb-kmod-0.6.6-1.2.6.23.1_49.fc8.src.rpm)
 Config(fedora-8-i386)
State Changed: init
State Changed: lock buildroot
State Changed: enabled yum cache, cleaning yum metadata
State Changed: enabled root cache
State Changed: unpacking cache
State Changed: running yum
State Changed: setup
State Changed: build
INFO:
Done(/home/lkundrak/rpmbuild/SRPMS/qc-usb-kmod-0.6.6-1.2.6.23.1_49.fc8.src.rpm)
Config(fedora-8-i386) 1 minutes 0 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-8-i386/result
INFO: Start(/home/lkundrak/rpmbuild/SRPMS/qc-usb-0.6.6-1.fc8.src.rpm) 
Config(fedora-8-i386)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
State Changed: enabled yum cache, cleaning yum metadata
State Changed: enabled root cache
State Changed: unpacking cache
State Changed: running yum
State Changed: setup
State Changed: build
INFO: Done(/home/lkundrak/rpmbuild/SRPMS/qc-usb-0.6.6-1.fc8.src.rpm)
Config(fedora-8-i386) 0 minutes 35 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-8-i386/result
$ 

What's left in /var/lib/mock/fedora-8-i386/result is:

qc-usb-0.6.6-1.fc8.i686.rpm
qc-usb-0.6.6-1.fc8.src.rpm
qc-usb-debuginfo-0.6.6-1.fc8.i686.rpm

What is -- just the second package, and no logs.
This used to work.

Version-Release number of selected component (if applicable):

mock-0.8.9-1.fc8

Additional info:

Please notice that setarch command. One would expect mock do that when passed
--arch. Not sure if it is worth having its own bug/enhancement ticket in bugzilla.
Comment 1 Michael E Brown 2007-12-01 03:40:45 EST
As far as I could tell, this was working in 0.8.9, but was broken in 0.8.10 and
0.8.11 (due to internal_dev_setup changes)

I have committed a fix to upstream git repo for this, it will show up in 0.8.12.

mock has had internal setarch since 0.8.8. Prior versions of mock had documented
that you must run setarch, but it is now completely optional.

It will take a week or two for this to show up in fedora, if you wish to try out
the fixed version, please check out upstream git repo.
Comment 2 Michael E Brown 2007-12-04 18:42:53 EST
Apologies. I overlooked something...

when building multiple srpms, "--resultdir=..." is required, otherwise the
"clean" that happens removes all prior rpm builds.

I have updated mock for 0.8.15 such that it now gives a helpful error message
when this situation is encountered. This way nobody else will run into this
behaviour.

Thanks for the bug report.

Mock 0.8.15 wont be released for another week or so. If you want to check this,
please checkout the upstream git repo.

Note You need to log in before you can comment on or make changes to this bug.