Bug 40730 - ide DVD/CDRW doesn't work with ide-scsi
ide DVD/CDRW doesn't work with ide-scsi
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 11:22 EDT by Frank Sweetser
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 15:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (4.97 KB, text/plain)
2001-05-16 11:09 EDT, Frank Sweetser
no flags Details

  None (edit)
Description Frank Sweetser 2001-05-15 11:22:27 EDT
Additional Information:
	Just installed on a Dell OptiPlex, which has an IDE DVD/CDRW drive:

hdc: SAMSUNG CDRW/DVD SM-308B, ATAPI CD/DVD-ROM drive

The install detected it, and set up ide-scsi emulation.  Fine.  However,
it doesn't seem to work, so far either with cdrecord or cdparanoia.

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: SAMSUNG   Model: CDRW/DVD SM-308B  Rev: M002
  Type:   CD-ROM                             ANSI SCSI revision: 02

cdparanoia errors out with

Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for cooked ioctl() interface
                /dev/scd0 is not a cooked ioctl CDROM.
        Testing /dev/cdrom for SCSI interface
                No generic SCSI device found to match CDROM device /dev/scd0

and cdrecord just hangs.  Nothing appears in dmesg output.  the drive
will mount cd's fine, though, and grip is able to get a listing of all
songs on an audio cd.
Comment 1 Arjan van de Ven 2001-05-15 11:25:57 EDT
Can you attache the full output of dmesg ?
Comment 2 Frank Sweetser 2001-05-16 11:09:16 EDT
Created attachment 18630 [details]
dmesg log
Comment 3 Frank Sweetser 2001-05-24 17:09:43 EDT
identical behavior with 2.4.3-5
Comment 4 Frank Sweetser 2001-05-25 12:08:31 EDT
Some improvement with 2.4.3-7.  cdparanoia rips audio fine.  cdrecord, however,
still ends up hanging with ide reset messages:

May 25 12:06:45 erwin kernel: scsi : aborting command due to timeout : pid 0, sc
si0, channel 0, id 0, lun 0 Start/Stop Unit 00 00 00 01 00
May 25 12:06:45 erwin kernel: hdc: irq timeout: status=0xd0 { Busy }
May 25 12:06:45 erwin kernel: hdc: DMA disabled
May 25 12:06:45 erwin kernel: hdc: ATAPI reset complete
May 25 12:06:45 erwin kernel: hdc: irq timeout: status=0x80 { Busy }
May 25 12:06:51 erwin kernel: hdc: ATAPI reset complete
May 25 12:06:51 erwin kernel: hdc: irq timeout: status=0x80 { Busy }
May 25 12:06:51 erwin kernel: hdc: status timeout: status=0x80 { Busy }
May 25 12:06:51 erwin kernel: hdc: drive not ready for command
May 25 12:06:51 erwin kernel: hdc: ATAPI reset complete
May 25 12:07:26 erwin kernel: scsi : aborting command due to timeout : pid 0, sc
si0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00
May 25 12:07:26 erwin kernel: hdc: irq timeout: status=0x80 { Busy }
May 25 12:07:26 erwin kernel: hdc: ATAPI reset complete
May 25 12:07:26 erwin kernel: hdc: irq timeout: status=0x80 { Busy }
Comment 5 Arjan van de Ven 2001-05-25 12:12:59 EDT
These messages look like a UDMA problem. Do you have a 80-ribbon cable?
Could you try "ide=nodma" on the commandline ?
Comment 6 Frank Sweetser 2001-05-25 12:23:37 EDT
hda => hard drive, UDMA with the 80 pin high density ribbon cable.
hdc => cdrw/dvd drive, with standard ide ribbon cable.
no hdb or hdd.

booted with ide=nodma (/proc/ide/piix shows dma is disabled on all devices),
exact same results.
Comment 7 Frank Sweetser 2001-05-29 15:06:02 EDT
kernel 2.4.5-0.2.i686, same results with and without ide=nodma
Comment 8 Frank Sweetser 2002-02-18 23:47:49 EST
<sigh...> after sufficient mucking about and hardware swapping, it looks like
all of the identical drives in the several identical machines I tried it on were
bad, as a batch of RMAs fixes the problem on all of them.

Note You need to log in before you can comment on or make changes to this bug.