Bug 40731 - The result of df -i on nfs file system is zero
The result of df -i on nfs file system is zero
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Ofer Alfassi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 11:33 EDT by Ofer Alfassi
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 15:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ofer Alfassi 2001-05-15 11:33:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 95; DigExt; compaq)

Description of problem:
Hello,
One of our customers has a few Redhat Linux V6.2 systems with kernel 
V2.2.14
(which supplier with R.H V6.2) 
When he has using with statfs function or  "df -i" command (to get 
statistic
information) on NFS file systems  all the statistic results equal to zero 
but on local file system it work well. 


BTW I reproduced the problem in the office and  received the same problem.

[root@pluto /]#  mount tavosf:/pub1 /mnt
[root@pluto /]#  df -i /mnt
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
tavosf:/pub1               0       0       0    -  /mnt
[root@pluto /]#  df -i /usr
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/sda5             193152   76257  116895   39% /usr


Do you have any information about this problem (looking like a system 
bug) ?

Thanks
Ofer 


How reproducible:
Always

Steps to Reproduce:
1.mount any nfs file system on R.H 6.2 (mount hostname:/share /mnt)
2.Run the command df -i /mnt  
3.
	

Actual Results:  Filesystem            Inodes   IUsed   IFree IUse% 
Mounted on
tavosf:/pub1               0       0       0    -  /mnt


Additional info:
Comment 1 Elliot Lee 2004-08-23 15:48:11 EDT
Seems to work these days...

(Sorry, bug got ignored because you assigned it to yourself.)

Note You need to log in before you can comment on or make changes to this bug.