Bug 407491 - wine causes total system freeze
wine causes total system freeze
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 14:25 EST by Andrew Ziem
Modified: 2007-12-09 03:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 03:55:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wine notepad &>wine_notepad.log (17.44 KB, text/plain)
2007-12-03 21:27 EST, Andrew Ziem
no flags Details

  None (edit)
Description Andrew Ziem 2007-12-01 14:25:32 EST
Description of problem:
Wine freezes system completely.  GNOME system monitor stops updating.  Num lock
not responsive.  CTRL+ALT+F1 not responsive.  Power button on computer no longer
provides soft shutdown.  A hard shutdown is required.


Version-Release number of selected component (if applicable):
wine-core-0.9.48-1.fc7
wine-core-0.9.49-1.fc7
kernel-2.6.23.8-34.fc7


How reproducible:
100%

Steps to Reproduce:
1. $wine notepad

Actual results:
System frozen completely.

Expected results:
System should not freeze.  :)


Additional info:
Comment 1 Andreas Bierfert 2007-12-02 08:55:34 EST
First of all: NEVER set a priority for a bug yourself. This is something that
should be done by the one reading and working on the bug.

Secondly: Could you please check why you have two versions of wine installed? It
seems to me that something with your system is wrong if there are two versions
installed at the same time because this should never be the case. One solution
would be to remove all wine packages and reinstall e.g. via:

`yum remove wine*`

check with `rpm -qa | grep wine` if all wine packages are gone (if not remove
them manually via rpm) and then reinstall the latest version via
`yum install wine`

Please also follow the instructions on moving your wine files out of the way
stated at http://fedoraproject.org/wiki/AndreasBierfert/Wine.

Comment 2 Andrew Ziem 2007-12-02 10:40:16 EST
(In reply to comment #1)
> First of all: NEVER set a priority for a bug yourself. This is something that
> should be done by the one reading and working on the bug.

Sorry.  I was not aware of that policy.

> Secondly: Could you please check why you have two versions of wine installed? 
> seems to me that something with your system is wrong if there are two versions
> installed at the same time because this should never be the case. One solution
> would be to remove all wine packages and reinstall e.g. via:
> 
> `yum remove wine*`
> 
> check with `rpm -qa | grep wine` if all wine packages are gone (if not remove
> them manually via rpm) and then reinstall the latest version via
> `yum install wine`

Sorry, I only meant to imply I tried the two versions.  I have only had one
version installed at one time.  To be more specific:

# rpm -qa| grep wine
wine-tools-0.9.49-1.fc7
wine-core-0.9.49-1.fc7

> Please also follow the instructions on moving your wine files out of the way
> stated at http://fedoraproject.org/wiki/AndreasBierfert/Wine.

Good idea.  I should have thought of that, but I tried it with the same results.
  For what it's worth:

$ wine

does not crash the system.   When I run

$ rm -rf ~/.wine; wine notepad

I can see line of one output about creating the home directory.  Then, the
system totally freezes.

I also tried running the Microsoft PowerPoint viewer installer, so the problem
is not specific to the Wine notepad.
Comment 3 Andreas Bierfert 2007-12-02 13:36:18 EST
Really strange I can not reproduce this here. Do you have selinux enabled? What
wine subpackages do you have installed? Would it be possible for you to run e.g
strace wine notepad and attach the result here?
Comment 4 Andrew Ziem 2007-12-03 21:27:18 EST
Created attachment 276501 [details]
wine notepad &>wine_notepad.log

1. SELinux is disabled and likely mostly/all uninstalled.

2. Before, I had wine-tools and wine-core, but now I just have -core.

3. See log attached.  I tried with both kernel-2.6.23.1-21.fc7 and
kernel-2.6.23.8-34.fc7.  The former is from the stable repo but the latter is
not.
Comment 5 Andreas Bierfert 2007-12-04 02:33:27 EST
Ah :) (2) might be the reason. Could you try to install the wine meta package
(which pulls in the usual set if wine things). I had bug reports in the past
with behavior like this that was caused by missing components. Just do `yum
install wine`.
Comment 6 Andrew Ziem 2007-12-08 20:26:58 EST
Sorry, problem was xorg-x11-drv-openchrome-0.2.900-7.fc7 .  I switched from
openchrome driver to via driver, and now I can run wine.  :)

Note You need to log in before you can comment on or make changes to this bug.