This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 407621 - unreasonable logrotate dependencies
unreasonable logrotate dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 21:46 EST by Chris Arrowood
Modified: 2007-12-03 02:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 02:37:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Arrowood 2007-12-01 21:46:33 EST
Description:
Attempting to remove logrotate attempts to take half of my system with it. 
There should be very few, if any, programs that actually require this to be
installed.  Certainly not >400.  A user may have an alternate method of managing
log files.

# yum remove logrotate
....
Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove     427 Package(s)

Is this ok [y/N]: Exiting on user Command

# uname -a
Linux <removed>.lan 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007 i686 i686
i386 GNU/Linux
Comment 1 Tomas Smetana 2007-12-03 02:37:40 EST
Any program that has a logrotate config file should require logrotate because
logrotate is a standard way how to prevent logs from filling all the disk.

If an user has the alternate method, he should just switch logrotate off (and
waste 76 kB of a disk space).  If you think that any package has unneeded
dependency on logrotate fill a bug on that package.

Logrotate itself requires SELinux libraries, popt and coreutils.

Note You need to log in before you can comment on or make changes to this bug.