Bug 407751 - battery and cpu therm problem 2.6.23
battery and cpu therm problem 2.6.23
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 06:00 EST by mike simpson
Modified: 2008-06-10 14:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.25.4-10.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 14:44:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg 2.6.23 (15.84 KB, text/plain)
2007-12-02 06:00 EST, mike simpson
no flags Details
dmesg 2.6.24 (16.87 KB, text/plain)
2007-12-02 06:01 EST, mike simpson
no flags Details
lspci -vv 2.6.23 (6.57 KB, text/plain)
2007-12-02 06:02 EST, mike simpson
no flags Details
lspci -vv 2.6.24 (6.52 KB, text/plain)
2007-12-02 06:02 EST, mike simpson
no flags Details

  None (edit)
Description mike simpson 2007-12-02 06:00:02 EST
Dell inspiron 2100 and toshiba s3000-x11 both have lost battery info and cpu
therm monitoring with 2.6.23 (all versions in fedora 7 and 8 and testing)
leading to severe overheating and failure to engage "laptop mode" when on battery

These are working with 2.6.22 and have been fixed with 2.6.24-0.57.rc3.git4

dmesg and lspci --vv for both in the atachments following
Comment 1 mike simpson 2007-12-02 06:00:02 EST
Created attachment 275031 [details]
dmesg 2.6.23
Comment 2 mike simpson 2007-12-02 06:01:06 EST
Created attachment 275041 [details]
dmesg 2.6.24
Comment 3 mike simpson 2007-12-02 06:02:06 EST
Created attachment 275051 [details]
lspci -vv 2.6.23
Comment 4 mike simpson 2007-12-02 06:02:57 EST
Created attachment 275061 [details]
lspci -vv 2.6.24
Comment 5 Kasper Dupont 2007-12-30 14:57:00 EST
I see this problem as well. kernel-2.6.23.1-42.fc8 works, with
kernel-2.6.23.9-85.fc8 there is no proc/acpi/battery/BAT0. Is any additional
information needed?
Comment 6 Ron Yorston 2007-12-30 17:38:20 EST
Just to confuse matters, 2.6.23.9-85.fc8 is the first FC8 kernel that works
properly for me.  This is on a Dell Latitude L400 (which is essentially the same
as the Inspiron 2100).
Comment 7 Kasper Dupont 2008-02-10 16:56:29 EST
Still broken in 2.6.23.14-115.fc8. A diff of dmesg output between the latest
working kernel and the latest kernel shows this:

@@ -159,6 +157,9 @@
 ACPI: Interpreter enabled
 ACPI: (supports S0 S1 S3 S4 S5)
 ACPI: Using IOAPIC for interrupt routing
+ACPI Error (evregion-0316): No handler for Region [RAM_] (f7cf0028)
[EmbeddedControl] [20070126]
+ACPI Error (exfldio-0289): Region EmbeddedControl(3) has no handler [20070126]
+ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.BAT0._STA]
(Node f7cf2a20), AE_NOT_EXIST
 ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
 ACPI: PCI Root Bridge [PCI0] (0000:00)
 Force enabled HPET at base address 0xfed00000
Comment 8 Kasper Dupont 2008-02-16 10:35:10 EST
Looks like this works again after upgrading to kernel-2.6.23.15-137.fc8.
Comment 9 Kasper Dupont 2008-04-06 11:46:49 EDT
Looks like this bug was reintroduced in 2.6.24.3-50.fc8. I tested battery
information on all fc8 kernel versions:

2.6.23.1-42.fc8   works
2.6.23.8-63.fc8   works
2.6.23.9-85.fc8   does not work
2.6.23.14-107.fc8 does not work
2.6.23.14-115.fc8 does not work
2.6.23.15-137.fc8 works
2.6.24.3-12.fc8   works
2.6.24.3-34.fc8   works
2.6.24.3-50.fc8   does not work
2.6.24.4-64.fc8   does not work
Comment 10 Kasper Dupont 2008-04-30 16:07:45 EDT
The bug is still present in kernel-2.6.24.5-85.fc8
Comment 11 Kasper Dupont 2008-06-01 17:41:43 EDT
This bug is still present in 2.6.24.7-92.fc8!

I wanted to try to track this down in the source, when this bug was
reintroduced. But I cannot find the following source rpm packages anywhere:
kernel-2.6.24.3-12.fc8.src.rpm
kernel-2.6.24.3-34.fc8.src.rpm
kernel-2.6.24.3-50.fc8.src.rpm
kernel-2.6.24.4-64.fc8.src.rpm
kernel-2.6.24.5-85.fc8.src.rpm
Comment 12 Kasper Dupont 2008-06-08 16:47:10 EDT
It appears to be working again in 2.6.25.4-10.fc8. Now we just need this bug not
to be reintroduced again a few releases down the way.

Note You need to log in before you can comment on or make changes to this bug.