Bug 40799 - am-utils-6.0.4s5 won't recompile
am-utils-6.0.4s5 won't recompile
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: am-utils (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 19:37 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 15:33:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-15 19:37:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
am-utils won't recompile on an updated 7.0 system.

How reproducible:
Always

Steps to Reproduce:
1.Apply all 7.0 updates
2.rpm -i am-utils-6.0.4s5-8.src.rpm
3.rpm -bc /usr/src/redhat/SPECS/am-utils.spec
	

Actual Results:  [...]
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include    -O2 -march=i386
-mcpu=i686   -c info_ndbm.c 
info_ndbm.c:62: parse error before `*'
info_ndbm.c: In function `search_ndbm':
info_ndbm.c:64: `datum' undeclared (first use in this function)
info_ndbm.c:64: (Each undeclared identifier is reported only once
info_ndbm.c:64: for each function it appears in.)
info_ndbm.c:64: parse error before `k'
info_ndbm.c:66: `k' undeclared (first use in this function)
info_ndbm.c:66: `key' undeclared (first use in this function)
info_ndbm.c:68: `v' undeclared (first use in this function)
info_ndbm.c:68: `db' undeclared (first use in this function)
info_ndbm.c:70: `val' undeclared (first use in this function)
info_ndbm.c: In function `ndbm_search':
info_ndbm.c:80: `DBM' undeclared (first use in this function)
info_ndbm.c:80: `db' undeclared (first use in this function)
info_ndbm.c: In function `ndbm_init':
info_ndbm.c:111: `DBM' undeclared (first use in this function)
info_ndbm.c:111: `db' undeclared (first use in this function)


Expected Results:  Compile without error.

Additional info:

It would be a huge win to recompile am-utils with the 2.2.19 kernel
in order to pick up NFSv3 and NFS over TCP support.  It looks like
the configure script is detecting the newly available features, but
now the package won't build.
A wild guess is that it's related to the new db3 update, but I haven't
investigated to see if that's true.  Nor have I tried recompiling it
on a stock 7.0 system to see if it ever worked.
Comment 1 C. Ray Ng 2001-08-16 16:22:27 EDT
Same problem trying to rebuild am-utils 6.0.6 against kernel-2.2.19-7.0.8
in a RH7.0 system:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include    -O2 -march=i386 -mcpu=i686   -c
info_ndbm.c
info_ndbm.c:62: parse error before `*'
info_ndbm.c: In function `search_ndbm':
info_ndbm.c:64: `datum' undeclared (first use in this function)
info_ndbm.c:64: (Each undeclared identifier is reported only once
info_ndbm.c:64: for each function it appears in.)
info_ndbm.c:64: parse error before `k'
info_ndbm.c:66: `k' undeclared (first use in this function)
info_ndbm.c:66: `key' undeclared (first use in this function)
info_ndbm.c:68: `v' undeclared (first use in this function)
info_ndbm.c:68: `db' undeclared (first use in this function)
info_ndbm.c:70: `val' undeclared (first use in this function)
info_ndbm.c: In function `ndbm_search':
info_ndbm.c:80: `DBM' undeclared (first use in this function)
info_ndbm.c:80: `db' undeclared (first use in this function)
info_ndbm.c: In function `ndbm_init':
info_ndbm.c:111: `DBM' undeclared (first use in this function)
info_ndbm.c:111: `db' undeclared (first use in this function)
make[2]: *** [info_ndbm.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/am-utils-6.0.6/amd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/am-utils-6.0.6'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.56317 (%build)

Note You need to log in before you can comment on or make changes to this bug.